Project

General

Profile

Actions

Bug #17914

closed

"Log in as user from another cluster" doesn't work on 9tee4 (peer federation with ce8i5)

Added by Peter Amstutz over 1 year ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
02/01/2022
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Description

  1. Went to 9tee4
  2. Selected "ce8i5" as my home cluster
  3. Got sent to a google login screen
  4. Redirected back somewhere
  5. Ended up kicked back at the 9tee4 login page

Subtasks 1 (0 open1 closed)

Task #18036: Review 17914-peer-federation-login-fixResolvedLucas Di Pentima02/01/2022

Actions
Actions #1

Updated by Peter Amstutz over 1 year ago

  • Description updated (diff)
Actions #2

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2021-07-21 sprint to 2021-08-04 sprint
Actions #3

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2021-08-04 sprint to 2021-08-18 sprint
Actions #4

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2021-08-18 sprint to 2021-09-01 sprint
Actions #5

Updated by Peter Amstutz over 1 year ago

  • Assigned To set to Lucas Di Pentima
Actions #6

Updated by Lucas Di Pentima over 1 year ago

  • Target version changed from 2021-09-01 sprint to 2021-09-15 sprint
Actions #7

Updated by Lucas Di Pentima over 1 year ago

  • Target version changed from 2021-09-15 sprint to 2021-09-29 sprint
Actions #8

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2021-09-29 sprint to 2021-10-13 sprint
Actions #9

Updated by Lucas Di Pentima over 1 year ago

  • Target version changed from 2021-10-13 sprint to 2021-10-27 sprint
Actions #10

Updated by Lucas Di Pentima over 1 year ago

  • Target version changed from 2021-10-27 sprint to 2021-11-24 sprint
Actions #11

Updated by Peter Amstutz about 1 year ago

  • Target version changed from 2021-11-24 sprint to 2021-12-08 sprint
Actions #12

Updated by Ward Vandewege about 1 year ago

  • Subject changed from "Log in as user from another cluster" doesn't work on 9tee4 to "Log in as user from another cluster" doesn't work on 9tee4 (peer federation with ce8i5)
Actions #13

Updated by Lucas Di Pentima about 1 year ago

  • Target version changed from 2021-12-08 sprint to 2022-01-05 sprint
Actions #14

Updated by Lucas Di Pentima about 1 year ago

  • Target version changed from 2022-01-05 sprint to 2021-12-08 sprint
Actions #15

Updated by Peter Amstutz about 1 year ago

  • Target version changed from 2021-12-08 sprint to 2022-01-05 sprint
Actions #16

Updated by Peter Amstutz about 1 year ago

  • Target version changed from 2022-01-05 sprint to 2022-01-19 sprint
Actions #17

Updated by Lucas Di Pentima about 1 year ago

  • Target version changed from 2022-01-19 sprint to 2022-02-02 sprint
Actions #18

Updated by Lucas Di Pentima about 1 year ago

  • Status changed from New to In Progress
Actions #19

Updated by Lucas Di Pentima 12 months ago

Updates at arvados-workbench2|f9d1c360 - branch 17914-peer-federation-login-fix
Test run: developer-tests-workbench2: #570

This regression was introduced in #17568, where in order to show the correct token's expiration date, we made the code to query the token issuer cluster instead of the one where the user just logged in.
This procedure is ok for LoginCluster-type federations, but for Peer-type ones, the created salted token doesn't allow the user to query the token issuer cluster directly, so it was getting a 401 error making the app init process fail.

The fixed code ensures that a LoginCluster-type federation is active before requesting the token data. The already existing test doesn't require any adjustment because it already tested a mocked LoginCluster configuration.

Actions #20

Updated by Lucas Di Pentima 12 months ago

Updates at arvados-workbench2|8b1d2274
Test run: developer-tests-workbench2: #571

Just a small improvement on the cypress test launch script to avoid modifying the committed arvados_config.yml file on every run.

Actions #21

Updated by Ward Vandewege 12 months ago

Lucas Di Pentima wrote:

Updates at arvados-workbench2|8b1d2274
Test run: developer-tests-workbench2: #571

Just a small improvement on the cypress test launch script to avoid modifying the committed arvados_config.yml file on every run.

This LGTM thank you!

Actions #22

Updated by Lucas Di Pentima 12 months ago

  • Status changed from In Progress to Resolved
Actions #23

Updated by Peter Amstutz 10 months ago

  • Release set to 46
Actions

Also available in: Atom PDF