Project

General

Profile

Actions

Bug #17952

closed

[workbench] Remove unused "compute nodes" UX (admin dropdown)

Added by Ward Vandewege over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
08/04/2021
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Description

This feature is unused since we retired node manager.


Subtasks 1 (0 open1 closed)

Task #17977: Review 17952-no-nodes-linkResolvedPeter Amstutz08/04/2021

Actions

Related issues

Blocks Arvados - Story #17953: [api] Remove unused "node" objectNew

Actions
Actions #1

Updated by Ward Vandewege over 2 years ago

  • Release set to 41
  • Description updated (diff)
  • Subject changed from [workbench] Remove unused compute nodes UX to [workbench] Remove unused "compute nodes" UX (admin dropdown)
Actions #2

Updated by Ward Vandewege over 2 years ago

  • Blocks Story #17953: [api] Remove unused "node" object added
Actions #3

Updated by Ward Vandewege over 2 years ago

  • Target version set to 2021-08-18 sprint
Actions #4

Updated by Peter Amstutz over 2 years ago

  • Target version changed from 2021-08-18 sprint to 2021-09-01 sprint
Actions #5

Updated by Peter Amstutz over 2 years ago

  • Target version changed from 2021-09-01 sprint to 2021-08-18 sprint
Actions #6

Updated by Peter Amstutz over 2 years ago

  • Assigned To set to Peter Amstutz
Actions #7

Updated by Peter Amstutz over 2 years ago

17952-no-nodes-link @ b5b64f5dcc4fa4614002e5a0969adba36ac7e5e8

Remove links to obsolete /nodes and /keep_disks pages.

developer-run-tests: #2618

Actions #8

Updated by Lucas Di Pentima over 2 years ago

There's a wb1 integration test failing with the following log:

21:59:24   3) Error:
21:59:24 ApplicationLayoutTest#test_test_system_menu_Keep_disks_link:
21:59:24 Capybara::ExpectationNotMet: expected to find css "a" with text "Keep disks" but there were no matches. Also found "Repositories", "Virtual machines", "SSH keys", "API tokens", "Links", "Users", "Groups", "Keep services", which matched the selector but not all filters.
21:59:24     test/integration/application_layout_test.rb:263:in `block (4 levels) in <class:ApplicationLayoutTest>'
21:59:24     test/integration/application_layout_test.rb:262:in `block (3 levels) in <class:ApplicationLayoutTest>'
21:59:24     test/integration/application_layout_test.rb:260:in `block (2 levels) in <class:ApplicationLayoutTest>'
21:59:24     test/test_helper.rb:358:in `capture_exceptions'
21:59:24     test/test_helper.rb:285:in `run'

Maybe this one isn't an intermittent failure.

Actions #9

Updated by Peter Amstutz over 2 years ago

Yea, that was a fire-and-forget test run, I didn't check it. Unsurprisingly the tests to check if those exact menu items were present failed, since they are no longer present. Removed them from the test list.

17952-no-nodes-link @ 3460f961868a965129edcf0947c69a7829a47a67

developer-run-tests: #2619

Actions #10

Updated by Lucas Di Pentima over 2 years ago

This LGTM, thanks!

Actions #11

Updated by Peter Amstutz over 2 years ago

  • % Done changed from 0 to 100
  • Status changed from New to Resolved
Actions

Also available in: Atom PDF