Bug #18002

ruamel.yaml and google-api-python-client are out of date and cause conflicts for users

Added by Peter Amstutz about 1 month ago. Updated 4 days ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
SDKs
Target version:
Start date:
09/15/2021
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-

Subtasks

Task #18159: Review 18002-update-python-deps ResolvedPeter Amstutz

History

#1 Updated by Peter Amstutz about 1 month ago

  • Target version changed from 2021-09-01 sprint to 2021-09-15 sprint

#2 Updated by Peter Amstutz 20 days ago

  • Target version deleted (2021-09-15 sprint)

#3 Updated by Peter Amstutz 5 days ago

  • Target version set to 2021-09-29 sprint

#4 Updated by Peter Amstutz 5 days ago

  • Assigned To set to Peter Amstutz

#5 Updated by Peter Amstutz 5 days ago

18002-update-python-deps @ 2bf1d2d554c33de560d6d1232c927010ac06e243

  • Update version pins on ruamel.yaml, google-api-python-client, cwltool, and schema salad.
  • Fix some tests mainly due to cwltool upgrade

https://ci.arvados.org/view/Developer/job/developer-run-tests/2689/

#6 Updated by Peter Amstutz 5 days ago

  • Status changed from New to In Progress

#7 Updated by Lucas Di Pentima 5 days ago

Just one small observation:

  • In files sdk/[python|cwl]/setup.py: I think the extra_require configs might not be needed anymore.
  • Other than that, LGTM.

#8 Updated by Peter Amstutz 4 days ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF