Bug #18029

NaN paging for Public Favorites when you click on the next page arrow on an empty data table

Added by Peter Amstutz 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Workbench2
Target version:
Start date:
09/10/2021
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-

Description

The problem can be reproduced by logging in on ce8i5's wb2, going to the "Public Favorites" section, and clicking on the "next page" icon at the bottom of the panel.

NaN pages.png (175 KB) NaN pages.png Lucas Di Pentima, 08/18/2021 07:49 PM
NaN pages after clicking.png (201 KB) NaN pages after clicking.png Lucas Di Pentima, 08/18/2021 07:49 PM

Subtasks

Task #18031: ReviewResolvedStephen Smith

Associated revisions

Revision b2f36a2b
Added by Stephen Smith about 2 months ago

Merge branch '18029-fix-nan-pagination' into main. Closes #18029

Arvados-DCO-1.1-Signed-off-by: Stephen Smith <>

History

#2 Updated by Lucas Di Pentima 2 months ago

  • Description updated (diff)

#3 Updated by Peter Amstutz 2 months ago

  • Assigned To set to Daniel Kutyła

#5 Updated by Peter Amstutz about 2 months ago

  • Target version changed from 2021-09-01 sprint to 2021-09-15 sprint

#6 Updated by Peter Amstutz about 2 months ago

  • Assigned To changed from Daniel Kutyła to Stephen Smith

#7 Updated by Stephen Smith about 2 months ago

Changes at arvados-workbench2|e983d1cc16a370a1cf0ab3dccc47049a34ef049d branch 18029-fix-nan-pagination
Tests https://ci.arvados.org/view/Developer/job/developer-tests-workbench2/477/

  • Fixed dividing by 0 in pagination in multiple places
  • Added a conditional disable to the next button on DataExplorer since mui pagination's default behavior seems to be not doing that automatically when there are no items

#8 Updated by Stephen Smith about 2 months ago

  • Status changed from New to In Progress

#9 Updated by Lucas Di Pentima about 2 months ago

Just one suggestion/question:

  • Do you think it would be better to resolve the "division by 0" issue on the reducer instead so that it's done just in one place?

Other than that, it LGTM.

Also available in: Atom PDF