Project

General

Profile

Actions

Bug #18257

closed

Chips error in workflow File/Directory array inputs

Added by Stephen Smith 9 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Workbench2
Target version:
Start date:
12/01/2021
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Description

Steps to reproduce:

  • Navigate to Run Process
  • Select an workflow with file or directory array inputs
  • Press next
  • Error

From 18115: The latest commit without this problem is arvados-workbench2|7edd5a7 which corresponds to version 2.2.1


Subtasks 1 (0 open1 closed)

Task #18270: Review 18257-chips-error-fixResolvedStephen Smith12/01/2021

Actions

Related issues

Related to Arvados - Bug #18116: Advanced search -> Search by properties -> Add crashesResolvedStephen Smith10/08/2021

Actions
Actions #1

Updated by Stephen Smith 9 months ago

  • Related to Bug #18116: Advanced search -> Search by properties -> Add crashes added
Actions #2

Updated by Stephen Smith 9 months ago

  • Description updated (diff)
Actions #3

Updated by Stephen Smith 9 months ago

  • Category set to Workbench2
Actions #4

Updated by Stephen Smith 9 months ago

  • Assigned To set to Lucas Di Pentima
Actions #5

Updated by Lucas Di Pentima 9 months ago

  • Target version set to 2021-10-27 sprint
Actions #6

Updated by Lucas Di Pentima 8 months ago

  • Target version changed from 2021-10-27 sprint to 2021-11-24 sprint
Actions #7

Updated by Peter Amstutz 8 months ago

  • Target version changed from 2021-11-24 sprint to 2021-12-08 sprint
Actions #8

Updated by Lucas Di Pentima 7 months ago

  • Status changed from New to In Progress
Actions #9

Updated by Lucas Di Pentima 7 months ago

Stephen Smith wrote:

Steps to reproduce:

  • Navigate to Run Process
  • Select an workflow with file or directory array inputs
  • Press next
  • Error

Thanks for the procedure! I'm able to reproduce the problem.

From 18115: The latest commit without this problem is arvados-workbench2|7edd5a7 which corresponds to version 2.2.1

I think in this case the problem is another thing. It happens to me in dev mode with commit 7edd5a7 and also the latest in main.

Actions #10

Updated by Lucas Di Pentima 7 months ago

Updates at arvados-workbench2|14f313e - branch 18257-chips-error-fix
Test run: developer-tests-workbench2: #523

While testing this with ce8i5-7fd4e-vejd8ttee0hj38v (thanks Stephen to submit a wf with so many different inputs!) I realized the issue wasn't the use of File and/or Directory array inputs but the problem appeared on float, string, and integers array inputs.
I've added additional checkings so that the app doesn't crash.
I haven't added tests because I'm not sure if this "run process" dialog will be the one we get to keep in the immediate future, but it can be easily check with the workflow mentioned above.

Actions #11

Updated by Stephen Smith 7 months ago

Looks good to me

Actions #12

Updated by Lucas Di Pentima 7 months ago

  • Status changed from In Progress to Resolved
Actions #13

Updated by Lucas Di Pentima 7 months ago

  • Release set to 48
Actions

Also available in: Atom PDF