Project

General

Profile

Actions

Bug #18391

closed

[go] FileSystem object does not refresh signatures resulting in read errors

Added by Joe Townsend 9 months ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
-
Category:
SDKs
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

The `FileSystem` created from a collection https://github.com/arvados/arvados/blob/main/sdk/go/arvados/fs_collection.go#L52 starts unexpectedly erroring after 14 days after creation when used to access the content of the collection.

This appears to be related to at these two issues: https://dev.arvados.org/issues/12308 and https://dev.arvados.org/issues/10008 although neither of those are Go specific.


Related issues

Is duplicate of Arvados - Bug #16727: [FUSE] [cgofuse] Refresh signatures / reload collection instead of using expired blob signaturesResolvedTom Clegg01/27/2022

Actions
Actions #1

Updated by Peter Amstutz 9 months ago

  • Is duplicate of Bug #16727: [FUSE] [cgofuse] Refresh signatures / reload collection instead of using expired blob signatures added
Actions #3

Updated by Tom Clegg 7 months ago

  • Status changed from New to Resolved

Applied in changeset arvados-private:commit:arvados|4cf58c672f91a0e4fec3ea3d4a1934c01b1fe214.

Actions

Also available in: Atom PDF