Project

General

Profile

Actions

Bug #18889

closed

arv-mount write crash

Added by Peter Amstutz 11 months ago. Updated 10 months ago.

Status:
Closed
Priority:
Normal
Assigned To:
Category:
FUSE
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

2022-03-17T01:38:28.229094200Z 2022-03-17 01:38:28 arvados.arvados_fuse[5111] ERROR: Unhandled exception during FUSE operation
2022-03-17T01:38:28.229094200Z Traceback (most recent call last):
2022-03-17T01:38:28.229094200Z   File "/usr/share/python3/dist/python3-arvados-fuse/lib/python3.7/site-packages/arvados_fuse/__init__.py", line 327, in catch_exceptions_wrapper
2022-03-17T01:38:28.229094200Z     return orig_func(self, *args, **kwargs)
2022-03-17T01:38:28.229094200Z   File "/usr/share/python3/dist/python3-arvados-fuse/lib/python3.7/site-packages/arvados_fuse/__init__.py", line 644, in read
2022-03-17T01:38:28.229094200Z     r = handle.obj.readfrom(off, size, self.num_retries)
2022-03-17T01:38:28.229094200Z   File "/usr/share/python3/dist/python3-arvados-fuse/lib/python3.7/site-packages/arvados_fuse/fusefile.py", line 66, in readfrom
2022-03-17T01:38:28.229094200Z     return self.arvfile.readfrom(off, size, num_retries, exact=True)
2022-03-17T01:38:28.229094200Z   File "/usr/share/python3/dist/python3-arvados-fuse/lib/python3.7/site-packages/arvados/arvfile.py", line 1107, in readfrom
2022-03-17T01:38:28.229094200Z     block = self.parent._my_block_manager().get_block_contents(lr.locator, num_retries=num_retries, cache_only=(bool(data) and not exact))
2022-03-17T01:38:28.229094200Z   File "/usr/share/python3/dist/python3-arvados-fuse/lib/python3.7/site-packages/arvados/arvfile.py", line 785, in get_block_contents
2022-03-17T01:38:28.229094200Z     return self._keep.get(locator, num_retries=num_retries)
2022-03-17T01:38:28.229094200Z   File "/usr/share/python3/dist/python3-arvados-fuse/lib/python3.7/site-packages/arvados/retry.py", line 177, in num_retries_setter
2022-03-17T01:38:28.229094200Z     return orig_func(self, *args, **kwargs)
2022-03-17T01:38:28.229094200Z   File "/usr/share/python3/dist/python3-arvados-fuse/lib/python3.7/site-packages/arvados/keep.py", line 1056, in get
2022-03-17T01:38:28.229094200Z     return self._get_or_head(loc_s, method="GET", **kwargs)
2022-03-17T01:38:28.229094200Z   File "/usr/share/python3/dist/python3-arvados-fuse/lib/python3.7/site-packages/arvados/keep.py", line 1093, in _get_or_head
2022-03-17T01:38:28.229094200Z     locator = KeepLocator(loc_s)
2022-03-17T01:38:28.229094200Z   File "/usr/share/python3/dist/python3-arvados-fuse/lib/python3.7/site-packages/arvados/keep.py", line 67, in __init__
2022-03-17T01:38:28.229094200Z     self.md5sum = next(pieces)
2022-03-17T01:38:28.229094200Z   File "/usr/share/python3/dist/python3-arvados-fuse/lib/python3.7/site-packages/arvados/keep.py", line 102, in setter
2022-03-17T01:38:28.229094200Z     format(name, length, hex_str))
2022-03-17T01:38:28.229094200Z ValueError: md5sum is not a 32-digit hex string: '26db3b16-c6d7-4de0-946e-7352992d752a'

The UUID is a placeholder for a block that hasn't been written yet, so this is probably a race condition.

Actions #1

Updated by Peter Amstutz 11 months ago

  • Assigned To set to Peter Amstutz
  • Category set to FUSE
  • Description updated (diff)
Actions #2

Updated by Peter Amstutz 11 months ago

  • Description updated (diff)
Actions #3

Updated by Peter Amstutz 11 months ago

  • Status changed from New to In Progress
Actions #4

Updated by Peter Amstutz 11 months ago

This seems to have been caused by very limited RAM available, it didn't crash after increasing the RAM and keep cache.

Actions #5

Updated by Peter Amstutz 11 months ago

  • Status changed from In Progress to Closed
Actions

Also available in: Atom PDF