Project

General

Profile

Actions

Bug #18938

closed

[keepstore] misreports its version as 'dev' when starting up

Added by Ward Vandewege 11 months ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
03/30/2022
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-

Description

E.g. on pirca:

Mar 25 20:28:07 keep0.pirca.arvadosapi.com keepstore[3072]: {"PID":3072,"level":"info","msg":"keepstore dev starting, pid 3072","time":"2022-03-25T20:28:07.470116038Z"}
$ dpkg -l |grep keep
ii  keepstore                         2.3.3-1                      amd64        Keep storage daemon, accessible to clients on the LAN
$ keepstore --version
keepstore 2.3.3 (go1.17.1)

Subtasks 1 (0 open1 closed)

Task #18955: ReviewResolvedLucas Di Pentima03/30/2022

Actions

Related issues

Is duplicate of Arvados - Bug #18387: [keepstore] reports incorrect version number `dev` when run on the compute nodeResolvedTom Clegg11/16/2021

Actions
Actions #1

Updated by Ward Vandewege 11 months ago

  • Description updated (diff)
Actions #2

Updated by Tom Clegg 10 months ago

Pretty 80% sure this was fixed in #18387

Actions #3

Updated by Tom Clegg 10 months ago

  • Is duplicate of Bug #18387: [keepstore] reports incorrect version number `dev` when run on the compute node added
Actions #4

Updated by Peter Amstutz 10 months ago

  • Assigned To set to Tom Clegg
Actions #5

Updated by Tom Clegg 10 months ago

  • Status changed from New to In Progress
Actions #6

Updated by Tom Clegg 10 months ago

Confirmed already fixed:

{"ClusterID":"ce8i5","PID":28918,"level":"info","msg":"keepstore 2.4.0~dev20220316140424 (go1.17.1) starting, pid 28918","time":"2022-03-16T16:09:17.644391886Z"}
{"ClusterID":"ce8i5","PID":25475,"level":"info","msg":"keepstore 2.4.0~dev20220318195919 (go1.17.1) starting, pid 25475","time":"2022-03-18T21:04:48.305000695Z"}
{"ClusterID":"ce8i5","PID":23963,"level":"info","msg":"keepstore 2.4.0~dev20220321141357 (go1.17.1) starting, pid 23963","time":"2022-03-21T15:22:01.938077503Z"}
{"ClusterID":"ce8i5","PID":25084,"level":"info","msg":"keepstore 2.4.0~dev20220321141729 (go1.17.1) starting, pid 25084","time":"2022-03-21T16:11:49.417345589Z"}
{"ClusterID":"ce8i5","PID":7477,"level":"info","msg":"keepstore 2.4.0~dev20220324152644 (go1.17.1) starting, pid 7477","time":"2022-03-24T16:46:02.459665914Z"}
{"ClusterID":"ce8i5","PID":23432,"level":"info","msg":"keepstore 2.4.0~dev20220328192819 (go1.17.1) starting, pid 23432","time":"2022-03-28T20:38:29.621164393Z"}
Actions #7

Updated by Tom Clegg 10 months ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF