Project

General

Profile

Actions

Bug #18966

closed

Requesting a non-visible collection UUID shows a blank page

Added by Lucas Di Pentima 5 months ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Workbench2
Start date:
04/04/2022
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Description

When a user attempts to view an existing collection that they don't have read access to, or a non-existing collection (but valid) UUID, the resulting UI is a blank page. (see attached screenshot)

From reading the browser's devtools networkl screen, it seems that collection is being request via a LIST call with all it's past versions, so a 404 response isn't available when the UUID cannot be accessed or doesn't exist.


Files

blank collection view.png (217 KB) blank collection view.png Lucas Di Pentima, 04/01/2022 05:12 PM

Subtasks 1 (0 open1 closed)

Task #18971: Review 18966-collection-not-found-uiResolvedStephen Smith04/04/2022

Actions

Related issues

Related to Arvados - Bug #18484: Direct links to Collections are retrieving the full manifest_text for no reason ResolvedLucas Di Pentima12/01/2021

Actions
Actions #1

Updated by Lucas Di Pentima 4 months ago

  • Assigned To set to Lucas Di Pentima
  • Status changed from New to In Progress
Actions #2

Updated by Lucas Di Pentima 4 months ago

  • Related to Bug #18484: Direct links to Collections are retrieving the full manifest_text for no reason added
Actions #3

Updated by Lucas Di Pentima 4 months ago

Updates at arvados-workbench2|c1c27e7f - branch 18966-collection-not-found-ui - developer-tests-workbench2: #640

  • Changes the collectionService.get() func to use a GET request instead of LIST. To avoid getting the manifest_text field, it passes a hardcoded list of default fields that excludes it.
  • Improves Cypress test related to the "not found" dialog, adding more cases, including collections.
  • Updates collectionService.get() unit tests to reflect the current behavior.
Actions #4

Updated by Lucas Di Pentima 4 months ago

Updates at arvados-workbench2|08c3068 - developer-tests-workbench2: #642

(previous test failure seems to be a caused by a new flaky test)

  • Changes Cypress config to avoid saving videos on successfull test cases. It saves ~15% of the current time it takes the whole run (around 5 minutes)
Actions #5

Updated by Stephen Smith 4 months ago

Only one minor thing - it looks like an it.only() snuck in from the main branch in the search spec L85, but otherwise everything passes and it LGTM!

Actions #6

Updated by Lucas Di Pentima 4 months ago

Updates at arvados-workbench2|41b06aa9 - developer-tests-workbench2: #643

  • Removes an it.only() call from the cypress/integration/search.spec.js test suite.
Actions #7

Updated by Lucas Di Pentima 4 months ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF