Project

General

Profile

Actions

Feature #19302

closed

Left side panel changes

Added by Lucas Di Pentima almost 2 years ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Workbench2
Story points:
3.0
Release relationship:
Auto

Description

  • "Shared with me" should no longer have a tree hanging off of it
  • However, "Favorites" and "Public favorites" should have at least one expandable level
  • When the left panel is collapsed using the ←| icon, a strip of icons should remain for easy access to those sections.
  • Can we increase the width of the target zone for the left panel size adjustment, it feels like it's only 1 pixel wide and is often frustrating to click on.
  • Reportedly the ←| doesn't show up on certain browsers, probably because I did a weird SVG trick to stretch it horizontally. We should either not stretch it at all, or adjust the icon directly.
Requires additional discussion:
  • Under "Home", limit it to 50 (?) items and instead of alphabetically, sort them in reverse chronological order by creation date

Subtasks 1 (0 open1 closed)

Task #21062: Review 19302-left-side-panel-changesResolvedPeter Amstutz11/09/2023Actions
Actions #1

Updated by Peter Amstutz almost 2 years ago

  • Target version changed from 2022-08-17 sprint to 2022-08-31 sprint
Actions #2

Updated by Peter Amstutz almost 2 years ago

  • Target version changed from 2022-08-31 sprint to 2022-09-14 sprint
Actions #3

Updated by Peter Amstutz almost 2 years ago

  • Target version changed from 2022-09-14 sprint to 2022-09-28 sprint
Actions #4

Updated by Peter Amstutz almost 2 years ago

  • Target version changed from 2022-09-28 sprint to 2022-10-12 sprint
Actions #5

Updated by Peter Amstutz almost 2 years ago

  • Target version changed from 2022-10-12 sprint to 2022-10-26 sprint
Actions #6

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2022-10-26 sprint to 2022-11-09 sprint
Actions #7

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2022-11-09 sprint to 2022-11-23 sprint
Actions #8

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2022-11-23 sprint to 2022-12-07 Sprint
Actions #9

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2022-12-07 Sprint to 2022-12-21 Sprint
Actions #10

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2022-12-21 Sprint to 2023-01-18 sprint
Actions #11

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2023-01-18 sprint to 2023-02-01 sprint
Actions #12

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2023-02-01 sprint to 2023-02-15 sprint
Actions #13

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2023-02-15 sprint to Future
Actions #14

Updated by Peter Amstutz 8 months ago

  • Target version changed from Future to Development 2023-11-08 sprint
Actions #15

Updated by Peter Amstutz 8 months ago

  • Subject changed from UX improvement: Left hand side tree state management. to Left side panel changes
  • Tracker changed from Bug to Feature
Actions #16

Updated by Peter Amstutz 8 months ago

  • Description updated (diff)
Actions #17

Updated by Peter Amstutz 8 months ago

  • Target version changed from Development 2023-11-08 sprint to Development 2023-10-25 sprint
Actions #18

Updated by Peter Amstutz 8 months ago

  • Description updated (diff)
Actions #19

Updated by Peter Amstutz 8 months ago

  • Story points set to 3.0
Actions #20

Updated by Peter Amstutz 8 months ago

  • Category deleted (Workbench2)
Actions #21

Updated by Peter Amstutz 8 months ago

  • Assigned To set to Lisa Knox
  • Category set to Workbench2
  • Project changed from Arvados Workbench 2 to Arvados
Actions #22

Updated by Peter Amstutz 7 months ago

  • Description updated (diff)
Actions #23

Updated by Peter Amstutz 7 months ago

  • Description updated (diff)
Actions #24

Updated by Peter Amstutz 7 months ago

  • Status changed from New to In Progress
Actions #25

Updated by Peter Amstutz 7 months ago

  • Target version changed from Development 2023-10-25 sprint to Development 2023-11-08 sprint
Actions #26

Updated by Peter Amstutz 7 months ago

  • Release set to 67
Actions #27

Updated by Peter Amstutz 7 months ago

While you are working on it, a couple of additional changes to the left panel I'd like to see:

  • Add a new item that navigates to "virtual-machines-user" called "Shell access" (you will probably need to pick an icon for this)
  • Put the items in this order
    • Home projects
    • My favorites
    • Public favorites
    • Shared with me
    • Workflow runs
    • Shell access
    • Groups
    • Trash
Actions #28

Updated by Lisa Knox 7 months ago

  • Need to add "Owner" to the "Shared with me" default columns
  • "Owner" items should be clickable links
Actions #29

Updated by Peter Amstutz 7 months ago

  • Target version changed from Development 2023-11-08 sprint to Development 2023-11-29 sprint
Actions #30

Updated by Lisa Knox 7 months ago

19302-left-side-panel-changes @ 2a0558ceed0332333908344cd1274d2827716d87

✅ "Shared with me" should no longer have a tree hanging off of it
✅ However, "Favorites" and "Public favorites" should have at least one expandable level

  • both now have one expandable level

✅ When the left panel is collapsed using the ←| icon, a strip of icons should remain for easy access to those sections.
✅ Can we increase the width of the target zone for the left panel size adjustment, it feels like it's only 1 pixel wide and is often frustrating to click on.

  • layout splitter width increased by 50%

✅ Reportedly the ←| doesn't show up on certain browsers, probably because I did a weird SVG trick to stretch it horizontally. We should either not stretch it at all, or adjust the icon directly.

  • I removed the svg stretching and it looked pretty bad with the new icons on the colapsed panel, so I just downloaded a new icon from material UI to match the rest of the MUI icons

✅ Under "Home", limit it to 50 (?) items and instead of alphabetically, sort them in reverse chronological order by creation date
✅ Need to add "Owner" to the "Shared with me" default columns
✅ Add a new item that navigates to "virtual-machines-user" called "Shell access" (you will probably need to pick an icon for this)
✅ Put the items in this order...
✅ Need to add "Owner" to the "Shared with me" default columns
✅ "Owner" items should be clickable links

  • done, but breadcrumbs don't reflect proper path when viewing another user's page

✅ All agreed upon points are implemented / addressed.
  • done, plus added "Owner" to Shared With Me panel default columns
✅ Anything not implemented (discovered or discussed during work) has a follow-up story.
  • breadcrumbs don't reflect proper path when viewing another user's page
✅ Code is tested and passing, both automated and manual, what manual testing was done is described ✅ Documentation has been updated.
  • n/a
✅ Behaves appropriately at the intended scale (describe intended scale).
  • sidepanel tree nodes are limited to 50 as discussed
✅ Considered backwards and forwards compatibility issues between client and server.
  • n/a

✅ Follows our coding standards and GUI style guidelines.

Also, I discovered a bug where the root of the "Home Projects" tree in the side panel has its intended icon overwritten by a plain projects logo when the rest of the projects are loaded. You can reproduce it by watching the icon next to "Home Projects" in the side panel and refreshing. I fixed the mistake and now the correct icon is always shown.

Actions #31

Updated by Peter Amstutz 7 months ago

Lisa Knox wrote in #note-30:

19302-left-side-panel-changes @ 2a0558ceed0332333908344cd1274d2827716d87

✅ Under "Home", limit it to 50 (?) items and instead of alphabetically, sort them in reverse chronological order by creation date

These still seem to be sorted alphabetically.

✅ Anything not implemented (discovered or discussed during work) has a follow-up story.
  • breadcrumbs don't reflect proper path when viewing another user's page

The checklist says "Anything not implemented (discovered or discussed during work) has a follow-up story" but you didn't link to a follow-up story. Or maybe we should just fix it on this ticket?

Actions #32

Updated by Lisa Knox 6 months ago

19302-left-side-panel-changes@e2f200c518a48a05bb8dba7682dbb445c19951df

✅ Under "Home", limit it to 50 (?) items and instead of alphabetically...

  • My mistake, I only applied the filtering to the new favorites/public favorites trees

✅ Anything not implemented (discovered or discussed during work) has a follow-up story.

Actions #33

Updated by Peter Amstutz 6 months ago

Lisa Knox wrote in #note-32:

19302-left-side-panel-changes@e2f200c518a48a05bb8dba7682dbb445c19951df

✅ Under "Home", limit it to 50 (?) items and instead of alphabetically...

  • My mistake, I only applied the filtering to the new favorites/public favorites trees

✅ Anything not implemented (discovered or discussed during work) has a follow-up story.

This LGTM!

Actions #34

Updated by Anonymous 6 months ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF