Project

General

Profile

Actions

Bug #19413

closed

Reporting many warnings is expensive

Added by Peter Amstutz about 1 month ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
CWL
Target version:
Start date:
08/24/2022
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
-
Release relationship:
Auto

Description

Customer has a workflow with a large number of hints that come from another workflow system that produce "unrecognized hint" on Arvados. These get reported to the API server. This gets slow because it is an API interaction each time, and the update operation is returning the entire container record which contains the entire workflow contents.


Subtasks 1 (0 open1 closed)

Task #19419: Review 19413-warning-updateResolvedPeter Amstutz08/24/2022

Actions
Actions #1

Updated by Peter Amstutz about 1 month ago

  • Status changed from New to In Progress
Actions #2

Updated by Peter Amstutz about 1 month ago

  • Description updated (diff)
Actions #3

Updated by Peter Amstutz about 1 month ago

19413-warning-update @ 7f510760c01e6a0c4509d29dc5966ee5a2129f22

developer-run-tests: #3269

  • There was already a limit imposed on how many warnings to show, the problem is that it would continue uselessly updating the runtime status, even though it was not making any changes to the text
  • New behavior, if the text won't change, don't update the record
  • Tested on customer workflow, confirmed it reduces workflow startup on the order of 10-15 minutes!
Actions #4

Updated by Lucas Di Pentima about 1 month ago

This LGTM, thanks!

Actions #5

Updated by Peter Amstutz about 1 month ago

  • Release set to 53
Actions #7

Updated by Peter Amstutz about 1 month ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF