Project

General

Profile

Actions

Feature #19482

closed

Linkable view panel for registered workflows

Added by Sarah Zaranek over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Workbench2
Story points:
2.5
Release relationship:
Auto

Description

there is no way to give someone a page to a registered workflow in wb2 because there is no registered workflow specific page - and when you "run" it it just goes to a generic run page like this -- https://workbench2.pirca.arvadosapi.com/run-process

this makes it really hard to even direct someone to a workflow to run if you have to send them to the project folder that contains it.

Design sketch:

Use a layout that's similar to the workflows panel.

  • Details panel (last modified, user that modified it, git details from the definition)
  • Inputs panel
  • Outputs panel
  • Files panel displaying the collection containing the workflow text
    • Get the workflow that was wrapped by looking into the wrapper workflow step and get the "run: keep:..." part that references the collection with the actual workflow
  • Stretch goal: render using https://github.com/rabix/cwl-svg #20094
  • Need to be able to navigate to it from projects list / by URL path
  • Side panel (already exists)
  • Button to launch the workflow ("Run" button already exists on the side panel)
  • Assume the structure of the "wrapper" workflow produced by Arvados cwl runner since 2.4.4, if it is registered by an earlier version and doesn't match, just don't display things that can't be displayed.

Files


Subtasks 1 (0 open1 closed)

Task #20112: Review 19482-wf-panelResolvedStephen Smith02/28/2023Actions

Related issues

Related to Arvados - Idea #20059: Redesign Register Workflow PanelNewActions
Related to Arvados - Bug #19932: CLI, python, CURL examples show every example code twiceResolvedPeter AmstutzActions
Blocks Arvados - Feature #20094: Render workflow with cwl-svgNewActions
Actions #1

Updated by Peter Amstutz over 1 year ago

  • Target version set to 2022-11-09 sprint
  • Assigned To set to Peter Amstutz
  • Category set to Workbench2
Actions #2

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2022-11-09 sprint to 2022-11-23 sprint
Actions #3

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2022-11-23 sprint to 2022-12-07 Sprint
Actions #4

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2022-12-07 Sprint to 2022-12-21 Sprint
Actions #5

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2022-12-21 Sprint to 2023-01-18 sprint
Actions #6

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2023-01-18 sprint to 2023-02-01 sprint
Actions #7

Updated by Peter Amstutz over 1 year ago

  • Category changed from Workbench2 to Workbench2
  • Subject changed from can't give someone a link to registered wf in wb2 to Linkable view panel for registered workflows
  • Project changed from Arvados Workbench 2 to Arvados
  • Tracker changed from Bug to Feature
Actions #8

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2023-02-01 sprint to Future
Actions #9

Updated by Sarah Zaranek over 1 year ago

  • Related to Idea #20059: Redesign Register Workflow Panel added
Actions #10

Updated by Peter Amstutz over 1 year ago

  • Description updated (diff)
Actions #11

Updated by Peter Amstutz over 1 year ago

Actions #12

Updated by Peter Amstutz over 1 year ago

  • Description updated (diff)
Actions #13

Updated by Peter Amstutz over 1 year ago

  • Story points set to 2.5
Actions #14

Updated by Peter Amstutz over 1 year ago

  • Description updated (diff)
Actions #15

Updated by Peter Amstutz over 1 year ago

  • Description updated (diff)
Actions #16

Updated by Peter Amstutz over 1 year ago

  • Description updated (diff)
Actions #17

Updated by Peter Amstutz over 1 year ago

  • Target version changed from Future to 2023-03-01 sprint
Actions #18

Updated by Peter Amstutz about 1 year ago

  • Release set to 57
Actions #19

Updated by Peter Amstutz about 1 year ago

Right-justify Run button.

Add three dot action menu.

Add standard items to context menu.

Fix breadcrumbs.

Actions #20

Updated by Peter Amstutz about 1 year ago

  • Related to Bug #19932: CLI, python, CURL examples show every example code twice added
Actions #21

Updated by Peter Amstutz about 1 year ago

19482-wf-panel @ c3bc34209f7dbbc80c62d8896af043c88cb6b9cf

developer-tests-workbench2: #1111

  • Adds new route for workflow panel
  • Displays details, Inputs, Outputs, and contents of the collection containing the workflow
  • Context menu now has basic operations on workflow record
Actions #22

Updated by Peter Amstutz about 1 year ago

  • Status changed from New to In Progress
Actions #23

Updated by Stephen Smith about 1 year ago

Aside from a couple notes it lgtm:

  • The breadcrumbs don't show the workflow you are currently viewing as the last item similar to other areas - the parent location should probably be blue / link color similar to other pages since it navigates to a different location
  • There seems to be some extra padding making the details card icon in the top left out of alignment with the other cards
  • Not sure if it's intentional for now but the back button after pressing run process returns to the old run process multi step form
Actions #24

Updated by Peter Amstutz about 1 year ago

  • Target version changed from 2023-03-01 sprint to Development 2023-03-15 sprint
Actions #25

Updated by Peter Amstutz about 1 year ago

Stephen Smith wrote in #note-23:

Aside from a couple notes it lgtm:

  • The breadcrumbs don't show the workflow you are currently viewing as the last item similar to other areas - the parent location should probably be blue / link color similar to other pages since it navigates to a different location

I'm confused, you should be seeing the name of the workflow, was there some way you navigated to it that didn't work?

  • There seems to be some extra padding making the details card icon in the top left out of alignment with the other cards

Good catch, I copied styling from collection panel when I should have copied it from the process panel. The collection panel has the same issue and to ensure consistent styling it should be migrated to use CardHeader/CardContent instead of just Grid.

  • Not sure if it's intentional for now but the back button after pressing run process returns to the old run process multi step form

I tried this and it took me back to the workflow panel? But I know navigation is a bit fussy.

Actions #26

Updated by Peter Amstutz about 1 year ago

19482-wf-panel @ arvados-workbench2|cd89fd24a8cdf7512a4352f1fc17101b225e32c4

Registered workflow panel and Collection panel use CardHeader/CardContent for more consistent styling.

Actions #27

Updated by Stephen Smith about 1 year ago

For the breadcrumbs, I started by navigating directly to the workflow url (/workflows/tordo-7fd4e-8kruxiw4pv5huh3), it works fine when I look at a collection in the same project, and the parent project shows up fine in the sidebar as well, but navigating to the workflow consistently doesn't show the item - the side panel parent project also loses the blue highlight so that might be related.

I also added a video of the wf run form back button issue, I can press the browser back button to get back to the wf panel but the form back button goes back to the workflow selector

Actions #28

Updated by Peter Amstutz about 1 year ago

  • Target version changed from Development 2023-03-15 sprint to Development 2023-03-29 Sprint
Actions #29

Updated by Peter Amstutz about 1 year ago

Stephen Smith wrote in #note-27:

For the breadcrumbs, I started by navigating directly to the workflow url (/workflows/tordo-7fd4e-8kruxiw4pv5huh3), it works fine when I look at a collection in the same project, and the parent project shows up fine in the sidebar as well, but navigating to the workflow consistently doesn't show the item - the side panel parent project also loses the blue highlight so that might be related.

I finally figured out why I couldn't reproduce it, we're looking at exactly the same workflow but you're looking at it in the "Shared with me" tree. When I look at something else in "Shared with me" I see the same behavior. Will fix.

I also added a video of the wf run form back button issue, I can press the browser back button to get back to the wf panel but the form back button goes back to the workflow selector

Ok. The browser back button does the right thing, but that "back" button at the bottom of the page is something else entirely. I'm not entirely sure there is a sensible fix here because that button works by switching the state to "step 1" rather than "navigate back". What do you think about just leaving it as-is? The plan is to rework Workflow launching and get rid of the two-step interface entirely in favor of creating an container request and editing it in place.

Actions #30

Updated by Peter Amstutz about 1 year ago

19482-wf-panel @ bf2e7c937e911629122eec14c29e8f6fa9b84aa6

developer-tests-workbench2: #1168

  • Fixed breadcrumbs for Workflow panel. Also fixed first-time-load breadcrumb display for collections and processes because they had similar issues.

I'm not completely happy with the existing architecture, this feels like something where the breadcrumb control be tasked with monitoring the currently item and working backwards to determine how to correctly render breadcrumbs, without requiring an explicit resource-specific "load" function. Getting this right was much trickier than it should have been.

Actions #31

Updated by Peter Amstutz about 1 year ago

Don't know if it is a flaky test or I broke something, re-running here

developer-tests-workbench2: #1169

Actions #32

Updated by Peter Amstutz about 1 year ago

Looks like flaky tests, maybe the breadcrumb changes messed up timing, I made some fixes:

developer-tests-workbench2: #1170

Actions #34

Updated by Peter Amstutz about 1 year ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF