Project

General

Profile

Actions

Bug #19715

closed

Preserving destination still not working consistently

Added by Peter Amstutz over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Workbench2
Target version:
Start date:
01/12/2023
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
1.0

Description

  1. I click on a link, for example:
    https://workbench2.tordo.arvadosapi.com/processes/tordo-xvhdp-u55x8qxyai66qu3
  2. My token is expired or for whatever reason I need to log in again, so I land on a login page.
  3. I click log in.
  4. I log in with Google.
  5. When I return, I am at the home project instead of the page for the link I clicked on.

Subtasks 1 (0 open1 closed)

Task #19924: Review 19715-preserve-url-autologoutResolvedLucas Di Pentima01/12/2023

Actions
Actions #1

Updated by Peter Amstutz over 1 year ago

  • Description updated (diff)
Actions #2

Updated by Peter Amstutz over 1 year ago

  • Target version changed from 2022-12-07 Sprint to 2022-12-21 Sprint
Actions #3

Updated by Peter Amstutz about 1 year ago

  • Story points set to 1.0
Actions #4

Updated by Peter Amstutz about 1 year ago

  • Target version changed from 2022-12-21 Sprint to 2023-01-18 sprint
Actions #5

Updated by Peter Amstutz about 1 year ago

  • Target version changed from 2023-01-18 sprint to 2023-02-01 sprint
Actions #6

Updated by Peter Amstutz about 1 year ago

  • Target version changed from 2023-02-01 sprint to 2023-01-18 sprint
Actions #7

Updated by Stephen Smith about 1 year ago

  • Assigned To set to Stephen Smith
Actions #8

Updated by Stephen Smith about 1 year ago

  • Status changed from New to In Progress
Actions #9

Updated by Stephen Smith about 1 year ago

Changes at arvados-workbench2|68abcff0f925ea12c0d74efdafbd6c74db82ae3b
Tests developer-tests-workbench2: #1056

  • Added preservePath flag to logout action, switches between returning to the base WB2 path vs the path the user was located before logging out - now preserves path when session times out

Tested by setting clusterConfig.Workbench.IdleTimeout to a small number

Actions #10

Updated by Lucas Di Pentima about 1 year ago

Your fix looks good and solves a real issue, but I don't think it is one reported on this ticket.
At first, I couldn't reproduce the problem described on this ticket: not being logged into tordo and clicking on the provided link using the current main version, I correctly get sent to the process page.
After some config fiddling, I think I came up with the specific case reported here: If workbench2's IdleTimeout is disabled or set to a value greater than TokenLifetime, it won't auto-logout and while being logged into wb2 and, your token gets expired, that's when the described problem appears: wb2 attempts to make some request and receives a 401 error, sending the user to the login page and completely forgetting where the user should get forwarded after login.
In summary: your updates are helpful because they fix another bug, but I think the one reported is still present. For the pending fix, I think you could write a Cypress test and simulate the token expiration by updating it directly via API requests.

Actions #11

Updated by Peter Amstutz about 1 year ago

  • Target version changed from 2023-01-18 sprint to 2023-02-01 sprint
Actions #12

Updated by Stephen Smith about 1 year ago

Changes at arvados-workbench2|e92b9b5472a0f32e40983b8e25e572e592691e41
Tests developer-tests-workbench2: #1061

  • Also fixed when the token expires before WB2 notices or is invalidated server sided
  • Modified token revokation test to ensure url is preserved
Actions #13

Updated by Lucas Di Pentima about 1 year ago

This LGTM, thanks!

Actions #14

Updated by Stephen Smith about 1 year ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF