Project

General

Profile

Actions

Idea #19830

closed

Write docstrings for arvados.util

Added by Brett Smith over 1 year ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Documentation
Start date:
11/21/2023
Due date:
Story points:
0.5
Release relationship:
Auto

Description

Ensure all public classes, methods, and functions in the arvados.util module have docstrings in our style.


Subtasks 1 (1 open0 closed)

Task #21210: Review 19830-pysdk-util-docsIn ProgressBrett Smith11/21/2023Actions

Related issues

Related to Arvados Epics - Idea #18800: Update Python SDK documentationIn ProgressActions
Actions #1

Updated by Brett Smith over 1 year ago

  • Related to Idea #18800: Update Python SDK documentation added
Actions #2

Updated by Peter Amstutz over 1 year ago

  • Release set to 59
Actions #3

Updated by Peter Amstutz over 1 year ago

  • Target version set to Future
Actions #4

Updated by Peter Amstutz over 1 year ago

  • Assigned To set to Brett Smith
Actions #5

Updated by Brett Smith over 1 year ago

  • Story points set to 0.5
  • Description updated (diff)
Actions #6

Updated by Brett Smith over 1 year ago

  • Description updated (diff)
Actions #7

Updated by Brett Smith over 1 year ago

  • Target version changed from Future to To be scheduled
Actions #8

Updated by Peter Amstutz 8 months ago

  • Target version changed from To be scheduled to Development 2023-11-08 sprint
Actions #9

Updated by Peter Amstutz 7 months ago

  • Target version changed from Development 2023-11-08 sprint to Development 2023-11-29 sprint
Actions #10

Updated by Peter Amstutz 7 months ago

  • Target version changed from Development 2023-11-29 sprint to Development 2024-01-03 sprint
Actions #11

Updated by Brett Smith 6 months ago

  • Target version changed from Development 2024-01-03 sprint to Development 2023-11-29 sprint
  • Status changed from New to In Progress
Actions #12

Updated by Brett Smith 6 months ago

19830-pysdk-util-docs @ 65a84ec3801f6b76ccc2e6af07511851b4dc3aba - developer-run-tests: #3917

The type annotations adedd in this branch refer to `arvados.api_resources.ArvadosAPIRequest`. This class is added in the branch for #21132. I have tested and confirmed that pdoc will render these references correctly after #21132 is merged.

While working on that, I had a moment where I thought I was going to need to make some adjustments to `run_test_server.py`. Thankfully I walked away from that ledge. But I did get as far as cleaning the imports, and that's a simple nice change so we might as well keep it. That's included.

  • All agreed upon points are implemented / addressed.
    • Yes
  • Anything not implemented (discovered or discussed during work) has a follow-up story.
    • N/A
  • Code is tested and passing, both automated and manual, what manual testing was done is described
    • Yes, see above
  • Documentation has been updated.
    • N/A
  • Behaves appropriately at the intended scale (describe intended scale).
    • N/A
  • Considered backwards and forwards compatibility issues between client and server.
    • N/A
  • Follows our coding standards and GUI style guidelines.
    • Yes
Actions #13

Updated by Lucas Di Pentima 6 months ago

Really nice, LGTM.

Actions #14

Updated by Brett Smith 6 months ago

  • % Done changed from 0 to 100
  • Status changed from In Progress to Resolved
Actions #15

Updated by Brett Smith 6 months ago

  • Release set to 67
Actions

Also available in: Atom PDF