Project

General

Profile

Actions

Feature #20218

closed

Container log endpoint in controller that routes to either crunch-run or keep-web

Added by Peter Amstutz 12 months ago. Updated 11 months ago.

Status:
Duplicate
Priority:
Normal
Assigned To:
-
Category:
Crunch
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

https://dev.arvados.org/projects/arvados/wiki/Efficient_live_access_to_container_logs

New endpoint

/arvados/v1/containers/{uuid}/log/{file}.txt

Client makes a WebDAV request for the log collection.

If container logs don't exist yet, make an empty response.

If the container is running, route to crunch-run instance.

If the container is completed, route to keep-web.


Related issues

Related to Arvados Epics - Story #16442: Scalable + reliable container loggingResolved03/15/202308/31/2023

Actions
Is duplicate of Arvados - Feature #19889: access current container logs at /arvados/v1/containers/{uuid}/log/{filename}ResolvedTom Clegg03/23/2023

Actions
Actions #1

Updated by Peter Amstutz 12 months ago

  • Description updated (diff)
Actions #2

Updated by Peter Amstutz 12 months ago

  • Related to Story #16442: Scalable + reliable container logging added
Actions #3

Updated by Peter Amstutz 12 months ago

  • Subject changed from Container log WebDAV endpoint that routes to either crunch-run or keep-web to Container log endpoint in controller that routes to either crunch-run or keep-web
Actions #4

Updated by Tom Clegg 12 months ago

  • Is duplicate of Feature #19889: access current container logs at /arvados/v1/containers/{uuid}/log/{filename} added
Actions #5

Updated by Tom Clegg 12 months ago

  • Status changed from New to Duplicate
Actions #6

Updated by Peter Amstutz 11 months ago

  • Target version deleted (To be groomed)
Actions

Also available in: Atom PDF