Project

General

Profile

Actions

Bug #20377

closed

Buggy process panel paging

Added by Peter Amstutz about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Workbench2
Story points:
2.0
Release relationship:
Auto

Description

I am seeing a strange behavior on both the "All Processes" panel and the Project panel when I change the "Rows per page" or click on the forward arrow on the process list.

The displayed value of "rows per page" or the expected range of entries changes for a second or two, then reverts back to the original value. The values displayed do seem to match the actual listing, but when I change it, it immediately changes it back, and the listing does not change. This is very irritating, and preventing me from being able to change the listing.

This is on a system where lots of processes are running and the process list is effectively being reloaded continuously to keep it up to date, that may be related.

Steps to reproduce:

  1. Go to tordo
  2. Go to "all processes"
  3. Click the right arrow 5 or 6 times. The range displayed for paging will go up to like 300-350, but when it finishes loading the 1st page, it'll snap back to 50-100

Similar situation:

  1. go to tordo-j7d0g-g8u498xbtioblwx
  2. show "intermediate" and "log" collections
  3. click the right arrow 5-6 times
  4. it'll do the same thing when the range goes up and then snaps back

Expected behavior: the page the user explicitly selects should be the page it eventually lands on. It should ignore or cancel the previous requests.


Subtasks 1 (0 open1 closed)

Task #20440: Review 20377-dataexplorer-paging-bugResolvedPeter Amstutz05/11/2023Actions
Actions #1

Updated by Peter Amstutz about 1 year ago

  • Description updated (diff)
Actions #2

Updated by Peter Amstutz about 1 year ago

  • Target version changed from Future to Development 2023-04-26 sprint
  • Assigned To set to Stephen Smith
Actions #3

Updated by Peter Amstutz about 1 year ago

  • Target version changed from Development 2023-04-26 sprint to Development 2023-05-10 sprint
Actions #5

Updated by Peter Amstutz about 1 year ago

  • Story points set to 2.0
Actions #6

Updated by Peter Amstutz about 1 year ago

  • Description updated (diff)
Actions #7

Updated by Peter Amstutz about 1 year ago

  • Description updated (diff)
Actions #8

Updated by Peter Amstutz about 1 year ago

  • Description updated (diff)
Actions #9

Updated by Peter Amstutz about 1 year ago

  • Target version changed from Development 2023-05-10 sprint to Development 2023-05-24 sprint
Actions #10

Updated by Stephen Smith about 1 year ago

  • Status changed from New to In Progress
Actions #11

Updated by Peter Amstutz about 1 year ago

  • Release set to 63
Actions #12

Updated by Stephen Smith about 1 year ago

Changes at arvados-workbench2|62f757227d45f1bbd338a0e27b22b8deb69f68b2 branch 20377-dataexplorer-paging-bug
Tests developer-tests-workbench2: #1215

  • Rejects dataexplorer updates when update data page doesn't match current dataexplorer page
    • This allows the correct page to load through the dataexplorer middleware retry logic since the page number doesn't get clobbered
  • Treats falsy values as 0 when performing the page comparison
Actions #13

Updated by Peter Amstutz about 1 year ago

Stephen Smith wrote in #note-12:

Changes at arvados-workbench2|62f757227d45f1bbd338a0e27b22b8deb69f68b2 branch 20377-dataexplorer-paging-bug
Tests developer-tests-workbench2: #1215

  • Rejects dataexplorer updates when update data page doesn't match current dataexplorer page
    • This allows the correct page to load through the dataexplorer middleware retry logic since the page number doesn't get clobbered
  • Treats falsy values as 0 when performing the page comparison

This LGTM.

But to note for future improvement, it would be nice if it could buffer the clicks a little bit so if I rapidly click 10 times to go 10 pages ahead it doesn't send requests for all 10 pages.

Actions #14

Updated by Stephen Smith about 1 year ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF