Project

General

Profile

Actions

Bug #20487

closed

Workflow inputs display flickering

Added by Peter Amstutz 12 months ago. Updated 12 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Workbench2
Story points:
-
Release relationship:
Auto

Description

Visiting the details panel for a registered workflow, it shows the inputs and outputs briefly, then they go away.


Subtasks 1 (0 open1 closed)

Task #20494: Review 20487-inputs-displayResolvedPeter Amstutz05/09/2023Actions
Actions #1

Updated by Peter Amstutz 12 months ago

  • Description updated (diff)
Actions #2

Updated by Peter Amstutz 12 months ago

Also getting this:

Warning: validateDOMNesting(...): <pre> cannot appear as a descendant of <p>.
    in pre (at process-io-card.tsx:620)
    in span (at process-io-card.tsx:456)
    in p (created by Typography)
    in Typography (created by WithStyles(Typography))
    in WithStyles(Typography) (at process-io-card.tsx:453)
</pre>
Actions #3

Updated by Peter Amstutz 12 months ago

20487-inputs-display @ arvados-workbench2|be33bc8c17b2e12b96d176d16e60f8ebe3fe1c06

The bug was was that loading the registered workflow panel would call
loadProject() which would call openProjectPanel() which would dispatch
REQUEST_ITEMS for the project (which is 100% wasteful, because we're
not displaying the project contents).

However, the results from REQUEST_ITEMS (which excludes some fields in
the standard query) would replace the result that previously got the
complete workflow object. As a result the "definition" field went
away, which cause the inputs/outputs panels to go blank.

This switches the navigation action to call "openProjectPanel", and
have that begin by calling "loadProject". As a result, other places
that call loadProject no longer call openProjectPanel.

developer-tests-workbench2: #1200

Actions #4

Updated by Peter Amstutz 12 months ago

  • Assigned To set to Peter Amstutz
  • Status changed from New to In Progress
Actions #5

Updated by Stephen Smith 12 months ago

Few things I noticed:

  • Breadcrumbs don't seem to be functioning now
  • Side panel tree doesn't update when navigating through projects
  • Navigating to a process run freezes the tab for me
Actions #6

Updated by Peter Amstutz 12 months ago

Stephen Smith wrote in #note-5:

Few things I noticed:

  • Breadcrumbs don't seem to be functioning now
  • Side panel tree doesn't update when navigating through projects
  • Navigating to a process run freezes the tab for me

Yea, I messed up and it wasn't dispatching, so openProjectPanel wasn't actually running loadProject().

20487-inputs-display @ arvados-workbench2|6319203009ed914504e23ff263b090e6250709fa

Fixed a couple other things, tests running here:

developer-tests-workbench2: #1202

Actions #7

Updated by Peter Amstutz 12 months ago

20487-inputs-display @ arvados-workbench2|b3b7bc4a913960c0dd1cba50eb690534b15b37b4

More fussing with tests. Passing now.

developer-tests-workbench2: #1204

Actions #8

Updated by Peter Amstutz 12 months ago

  • Target version changed from Development 2023-05-10 sprint to Development 2023-05-24 sprint
Actions #9

Updated by Stephen Smith 12 months ago

Only a minor nit, needs a `===` on collection-panel-files.tsx:264, and groups-service.ts:59, but otherwise it looks good to me

Actions #10

Updated by Peter Amstutz 12 months ago

  • Status changed from In Progress to Resolved
Actions #11

Updated by Peter Amstutz 12 months ago

  • Release set to 63
Actions

Also available in: Atom PDF