Project

General

Profile

Actions

Bug #20619

closed

arvados-client deb package doesn't depend on libfuse

Added by Lucas Di Pentima about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
CI
Story points:
-
Release relationship:
Auto

Description

While working on an Ubuntu 20.04 node, I installed arvados-client and cannot run it because of libfuse not being installed:

$ ldd `which arvados-client`
        linux-vdso.so.1 (0x00007ffcc13b8000)
        libfuse.so.2 => not found
        libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f04633f7000)
        libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f0463000000)
        /lib64/ld-linux-x86-64.so.2 (0x00007f0463406000)
$ apt-cache depends arvados-client=2.6.2-1
arvados-client

Make sure our CI package testing pipeline tries running arvados-client -version correctly after install.


Subtasks 1 (0 open1 closed)

Task #20625: ReviewResolvedTom Clegg09/12/2023Actions
Actions

Also available in: Atom PDF