Project

General

Profile

Actions

Bug #20844

closed

Upgrade API server to Rails 6

Added by Brett Smith 11 months ago. Updated 11 months ago.

Status:
Duplicate
Priority:
Normal
Assigned To:
-
Category:
API
Target version:
-
Story points:
-

Description

This is necessary to support Ubuntu 22.04+, Debian 12+, and RHEL 9+: those distributions have OpenSSL 3.0, which is only supported by Ruby 3.x, which is only supported by Rails 6.

This ticket includes transient dependencies like our google-api-client fork:

Bundler could not find compatible versions for gem "activesupport":
  In Gemfile:
    arvados (~> 2.1.5) was resolved to 2.1.5, which depends on
      arvados-google-api-client (>= 0.7, < 0.8.9) was resolved to 0.8.7.4, which depends on
        activesupport (>= 3.2, < 5.3)

    rails (~> 6.0.0) was resolved to 6.0.1.rc1, which depends on
      activesupport (= 6.0.1.rc1)

Related issues

Is duplicate of Arvados - Idea #20300: RailsAPI upgrade from 5.2 to 7.0ResolvedTom Clegg10/06/2023Actions
Actions

Also available in: Atom PDF