Project

General

Profile

Actions

Bug #21209

closed

failed to load all processes page, net::ERR_FAILED

Added by Peter Amstutz 8 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Story points:
-

Description

We had reports of workbench occasionally failing to load content when under load. I recently saw a "failed to load process list" error and the browser console suggests that it is net::ERR_FAILED (which I am guessing is a TCP connection error?) instead of a HTTP error.

I'm wondering if either:

a) a connection that was thought to still be live with HTTP keepalive or HTTP/2 session actually wasn't, and that error pops up to the browser level
b) the number of sockets the load balancer can have open is much too low, or a CORS preflight check didn't go through

On further examination, it seems that net::ERR_FAILED is a generic error that can be caused by various reasons -- but it is still notable that it isn't a HTTP response.

Actions #1

Updated by Peter Amstutz 8 months ago

  • Status changed from New to In Progress
Actions #2

Updated by Peter Amstutz 8 months ago

  • Description updated (diff)
Actions #3

Updated by Peter Amstutz 8 months ago

Peter Amstutz wrote:

We had reports of workbench occasionally failing to load content when under load. I recently saw a "failed to load process list" error and the browser console suggests that it is net::ERR_FAILED (which I am guessing is a TCP connection error?) instead of a HTTP error.

I'm wondering if either:

a) a connection that was thought to still be live with HTTP keepalive or HTTP/2 session actually wasn't, and that error pops up to the browser level
b) the number of sockets the load balancer can have open is much too low, or a CORS preflight check didn't go through

On further examination, it seems that net::ERR_FAILED is a generic error that can be caused by various reasons -- but it is still notable that it isn't a HTTP response.

Actions #4

Updated by Peter Amstutz 8 months ago

  • Target version changed from Development 2023-11-29 sprint to Development 2024-01-03 sprint
Actions #5

Updated by Peter Amstutz 8 months ago

  • Target version changed from Development 2024-01-03 sprint to Development 2024-01-17 sprint
Actions #6

Updated by Peter Amstutz 7 months ago

  • Target version deleted (Development 2024-01-17 sprint)
  • Status changed from In Progress to Closed

I realize this isn't an actionable bug report so I'm just going to close this.

Actions

Also available in: Atom PDF