Project

General

Profile

Actions

Idea #21406

closed

Declare python_requires~=3.8 for all our Python packages

Added by Brett Smith 6 months ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Deployment
Start date:
Due date:
Story points:
0.5

Description

They might coincidentally work on older Pythons, but we're not testing or officially supporting that. sdk/cwl at least uses some stdlib functions that are new in 3.8.

Update:

  • sdk/python
  • services/fuse
  • sdk/cwl
  • services/dockercleaner

Related issues

Related to Arvados - Bug #21087: Python 3.7 deprecationResolvedBrett SmithActions
Related to Arvados - Idea #21454: Update required_ruby_version in all our gemspecsResolvedBrett SmithActions
Actions #1

Updated by Brett Smith 6 months ago

  • Related to Bug #21087: Python 3.7 deprecation added
Actions #2

Updated by Brett Smith 6 months ago

  • Subject changed from Declare python_requires>=3.8 for all our Python packages to Declare python_requires~=3.8 for all our Python packages
Actions #3

Updated by Brett Smith 6 months ago

  • Related to Idea #21454: Update required_ruby_version in all our gemspecs added
Actions #4

Updated by Brett Smith 5 months ago

  • Target version changed from To be scheduled to Development 2024-02-14 sprint
  • Assigned To set to Brett Smith
  • Status changed from New to Resolved
Actions

Also available in: Atom PDF