Bug #2209

arvados.api('v1').collections().list(limit=X).execute() returns ~half X results

Added by Tom Clegg almost 7 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
-
Category:
-
Start date:
03/23/2014
Due date:
% Done:

100%

Estimated time:
(Total: 4.50 h)
Story points:
1.0
Release:
Release relationship:
Auto

Subtasks

Task #2373: Figure out why, and fix. Start with paging branch.ClosedTom Clegg

Task #2491: Reproduce "available > returned < limit" and write testResolvedTom Clegg

Task #2410: Merge 2209 branch (it just adds some tests)ResolvedTom Clegg

Task #2493: Fix inaccurate items_available current user has permission to collection via multiple groups/links.ResolvedTom Clegg

Task #2494: Review 2209-correct-items-available branchResolvedTom Clegg

History

#1 Updated by Tom Clegg almost 7 years ago

  • Story points set to 1.0

#2 Updated by Tom Clegg over 6 years ago

  • Target version set to 2014-03-26 Debt service and dev painkillers

#3 Updated by Tom Clegg over 6 years ago

  • Status changed from New to In Progress

Could not reproduce. (Fixed in #2075?)

Adding tests for limit and offset params instead.

#4 Updated by Anonymous over 6 years ago

  • Status changed from In Progress to Resolved

Applied in changeset arvados|commit:8dd84d8f667aa40b9c8ce91d1a9248e1a7218039.

#5 Updated by Tom Clegg over 6 years ago

  • Status changed from Resolved to New

#6 Updated by Tom Clegg over 6 years ago

  • Target version changed from 2014-03-26 Debt service and dev painkillers to 2014-04-16 Dev tools and data/resource management

#7 Updated by Tom Clegg over 6 years ago

Misha can still reproduce. With limit=10000, server returns ~3000 items but claims ~4000 items_available.

#8 Updated by Brett Smith over 6 years ago

2209-correct-items-available looks like a nice clean branch to me. Just one thing: in the test, the assignment for unique_uuids doesn't seem to actually ensure uniqueness, as far as I can tell. Should it? That'd be easy to do with a set operator, like unique_uuids = [] | resp['items'].collect { |i| i['uuid'] }.compact.

Either way, I think this is good to merge.

#9 Updated by Anonymous over 6 years ago

  • Status changed from New to Resolved
  • % Done changed from 78 to 100

Applied in changeset arvados|commit:5a19b986fd10f0584b33eb5953e72bd373e487d2.

Also available in: Atom PDF