Bug #2759

Cannot view collection in workbench

Added by Tom Clegg over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Brett Smith
Category:
-
Start date:
05/08/2014
Due date:
% Done:

100%

Estimated time:
(Total: 1.00 h)
Story points:
1.0


Subtasks

Task #2785: Remove trailing %0A in Job→Collection linkResolvedTom Clegg

Associated revisions

Revision f900ccf5 (diff)
Added by Brett Smith over 7 years ago

2759: Workbench shouldn't try to make links from Link names.

Because the name attribute can include arbitrary text, it might
resemble an Arvados object UUID. If that happens, the
_arvados_attr_value partial will try to make a link from it. All
sorts of weirdness could happen as a result (our specific bug was a
bad URL fed to Workbench's API client), so don't even try. Just
render the name directly as editable text.

Closes #2759.

History

#1 Updated by Tom Clegg over 7 years ago

  • Description updated (diff)

#2 Updated by Brett Smith over 7 years ago

  • Assigned To set to Brett Smith

#3 Updated by Brett Smith over 7 years ago

  • Status changed from New to In Progress

The %0A thing is happening because the attribute actually ends in newline in the model. There are a few of these in the database, all from early April:

>>> res = {job['uuid']: job['created_at'] for job in api.jobs().list(filters=[['output', 'like', '%\n']]).execute()['items']}
>>> res.update({job['uuid']: job['created_at'] for job in api.jobs().list(filters=[['log', 'like', '%\n']]).execute()['items']})
>>> pp(sorted(res.iteritems(), key=lambda x: x[1]))
[(u'qr1hi-8i9sb-3rq7pgo1mh0y4ak', u'2014-04-03T16:19:05Z'),
 (u'qr1hi-8i9sb-gehsdws0ty4yxco', u'2014-04-03T16:25:48Z'),
 (u'qr1hi-8i9sb-sx57aa88lgsjhmb', u'2014-04-03T16:26:53Z'),
 (u'qr1hi-8i9sb-p7likt2n4uxwtxs', u'2014-04-03T16:27:49Z'),
 (u'qr1hi-8i9sb-lbdw4brwqwl0p1l', u'2014-04-03T16:29:12Z'),
 (u'qr1hi-8i9sb-r1eqn4mi7myx9he', u'2014-04-03T16:32:24Z'),
 (u'qr1hi-8i9sb-do76bup9z5gcnw3', u'2014-04-03T16:35:25Z'),
 (u'qr1hi-8i9sb-kixw9da64nkvma1', u'2014-04-03T16:39:51Z'),
 (u'qr1hi-8i9sb-nprz9x3mhzknuxh', u'2014-04-03T16:49:51Z'),
 (u'qr1hi-8i9sb-glqofiieztt7h1j', u'2014-04-03T17:52:20Z'),
 (u'qr1hi-8i9sb-92rrmh19eo90scn', u'2014-04-03T18:04:15Z'),
 (u'qr1hi-8i9sb-82kvcn9b5l4g6lq', u'2014-04-03T20:33:48Z'),
 (u'qr1hi-8i9sb-fhc6r9e59pbij2r', u'2014-04-03T20:34:36Z'),
 (u'qr1hi-8i9sb-4lue0or9veqidym', u'2014-04-03T20:37:30Z'),
 (u'qr1hi-8i9sb-634p8qlhbylgk8f', u'2014-04-03T20:38:11Z'),
 (u'qr1hi-8i9sb-b7z5uh3dlydkfl3', u'2014-04-03T20:39:08Z'),
 (u'qr1hi-8i9sb-5i46n8fh07oihv9', u'2014-04-03T20:41:05Z'),
 (u'qr1hi-8i9sb-sm9ut403g7w70zk', u'2014-04-04T15:05:57Z'),
 (u'qr1hi-8i9sb-g1zpegqla12e6ra', u'2014-04-04T15:07:20Z'),
 (u'qr1hi-8i9sb-7b6mcqd24yf374t', u'2014-04-04T15:22:18Z'),
 (u'qr1hi-8i9sb-4u2b5l4uj5u5xo0', u'2014-04-04T15:23:23Z'),
 (u'qr1hi-8i9sb-3ywt9axygnsrt3z', u'2014-04-04T15:24:18Z'),
 (u'qr1hi-8i9sb-47wc2ss49a679r9', u'2014-04-09T03:06:21Z'),
 (u'qr1hi-8i9sb-2ehrv669wdvp1bp', u'2014-04-09T03:06:57Z'),
 (u'qr1hi-8i9sb-lbvptw8i2nqiuka', u'2014-04-09T03:48:40Z'),
 (u'qr1hi-8i9sb-ab3vd2aq7nf5d9s', u'2014-04-09T03:55:10Z'),
 (u'qr1hi-8i9sb-r185fm46o487cdy', u'2014-04-09T03:55:50Z'),
 (u'qr1hi-8i9sb-3t30b0d5o9x0i49', u'2014-04-09T03:58:30Z'),
 (u'qr1hi-8i9sb-ee81ejxlk4gd5h9', u'2014-04-11T03:47:39Z'),
 (u'qr1hi-8i9sb-nml7pdhbky5808k', u'2014-04-11T03:48:25Z')]

My guess is that these were caused by a bug that has since been fixed. Should we fix the database with a migration, or… ?

#4 Updated by Brett Smith over 7 years ago

The crashing happens when app/views/application/_arvados_attr_value.html.erb:10 tries to render 4xphq-o0j2j-qnfomocnrdvznex, a name Link with the name '650e9bee8e8b97cb222a6933bd88e777+42 added 2014-05-07 16:49:32 +0000'. That name is being treated as a Collection UUID, and we try to look it up in the API server. app/models/arvados_api_client.rb:61 makes the request, which causes the exception.

#5 Updated by Brett Smith over 7 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Applied in changeset arvados|commit:f900ccf514a3653a64002fe07d9ce5b16adcfd51.

#6 Updated by Tom Clegg over 7 years ago

Brett Smith wrote:

The %0A thing is happening because the attribute actually ends in newline in the model. There are a few of these in the database, all from early April:

[...]

My guess is that these were caused by a bug that has since been fixed. Should we fix the database with a migration, or… ?

Fixed database entries @ qr1hi.

(Surely these resulted from bug half-fixed Apr8 in 71b0d0f and other-half-fixed just now in f990e68)

Also available in: Atom PDF