Bug #2862

Occasional rendering error when using 'back' button in workbench

Added by Abram Connelly over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
-
Category:
-
Start date:
05/25/2014
Due date:
% Done:

100%

Estimated time:
Story points:
1.0

Description

Occasionally when using the 'back' button when navigating the workbench, the workbench will not render.

A screenshot of what I see is attached. This happened after I went 'back' from following a log link from one of the recent jobs I ran. Hitting 'F5' reloads the page and it renders normally. The incorrect rendering does not always happen when I hit the 'back' button and I haven't been able to consistently trigger the issue (that is, it happens intermitantly).

backButtonRenderBug.png (266 KB) backButtonRenderBug.png Abram Connelly, 05/25/2014 11:03 PM

Associated revisions

Revision 9e4c1f16 (diff)
Added by Tom Clegg over 7 years ago

2862: Use ?format=js so browser does not think js and html views are
interchangeable. closes #2862

History

#1 Updated by Ward Vandewege over 7 years ago

  • Target version set to 2014-06-17 Curating and Crunch

#2 Updated by Ward Vandewege over 7 years ago

  • Story points set to 1.0

#3 Updated by Tom Clegg over 7 years ago

Caused by browser re-using the 'refresh' response (which is UJS "remote:true", i.e., javascript response) as the page content because the method is GET and the URI is the same.

Might be fixable by having Workbench set a "never cache this" header when responding with JavaScript content.

Could also add a useless ?partial=true to the target url to make sure the browser thinks it's a different URI.

#4 Updated by Anonymous over 7 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Applied in changeset arvados|commit:9e4c1f166766dcbd0cfc8bc17ff13f7a2dc8508d.

#5 Updated by Ward Vandewege over 7 years ago

  • Target version changed from 2014-06-17 Curating and Crunch to 2014-05-28 Pipeline Factory

Also available in: Atom PDF