Story #2872

Replace left nav with "projects/folders" interface

Added by Tom Clegg over 6 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Start date:
06/01/2014
Due date:
% Done:

100%

Estimated time:
(Total: 23.00 h)
Story points:
5.0

Subtasks

Task #2945: Tags and infinite scroll in collection chooser and folder contentsResolvedTom Clegg

Task #2944: Make basic pipeline/collection workflow stay in a project/folder contextResolvedTom Clegg

Task #2950: Get "compare pipelines" feature into folder presentationResolvedTom Clegg

Task #2974: Make existing tests passResolvedRadhika Chippada

Task #2977: Fix bugs and loose endsResolvedTom Clegg

Task #2946: Review 2872-folder-navResolvedTom Clegg

Associated revisions

Revision 902ff4f1 (diff)
Added by Tom Clegg over 6 years ago

2872: Ensure name link tail_uuid == owner_uuid. refs #2872

Revision 0558601e (diff)
Added by Tom Clegg over 6 years ago

2872: Change default order of folder contents. refs #2872

Revision 656769b7 (diff)
Added by Tom Clegg over 6 years ago

2872: Fix attribute_editable? to play nicer with group ownership. refs #2872

Revision cec09589
Added by Tom Clegg over 6 years ago

2872: Merge branch '2872-folder-nav' closes #2872

Revision 63c77731 (diff)
Added by Tom Clegg over 6 years ago

Fix infinite scroll in chooser. refs #2872

History

#1 Updated by Tom Clegg over 6 years ago

  • Assigned To set to Tom Clegg

#2 Updated by Peter Amstutz over 6 years ago

  1. Getting rid of left sidebar -- totally reject. Without the sidebar I feel totally lost in the application (it puts us back to where we were in January). Instead, I'd like to the sidebar primarily consist of folders -> an extension of what the sidebar is already doing in master.
  2. I like the using the pencil to indicate "edit this name" instead of the x-editable dotted underline. This allows us to have names be a clickable link instead of needing extra "show" or "go" buttons, which are awkward and take up space.

#3 Updated by Radhika Chippada over 6 years ago

As I worked on updating the test to meet the updated UI flow, I had a few observations about the new UI.

1. I felt the navigation within the UI is significantly more difficult without the left navigation. The "System tools" gear menu in the top nav is cool. However, it still does not make up for the left nav. It probably be desirable to use a combination of the two where the "System tools" gear is used to reduce the clutter in the left nav.

2. I think it is desirable that the pencil icon placement is consistently to the right (preferable) or left. It seems to be placed to the left in "Folder" list panel, at least in the "rename" a pipeline case. In other cases, it is appearing to the right.

3. The weirdest thing I have noticed is in the "Users" page. Under "Is Admin" column, I see a uuid instead of "True" like the "Is Active" column. I think this is very confusing and unnecessary? If there are other places like this, we should address them.

#4 Updated by Peter Amstutz over 6 years ago

New dashboard

  • For some reason, the page is about 5-10 times wider than the window width, so there is a horizontal scroll off into empty space.
  • My "Recent jobs and pipelines" is empty because it searches for things owned by my projects, but not owned by me directly
  • It would be nice if it showed who owned each folder shared with me

Folder page

  • Pencil icon to rename items within a project should be on the right side of the name for consistency
  • I don't like using a circle with a slash through it to indicate "delete", that icon is most often used to mean "forbidden" (eg "no smoking" "no parking"). Prefer an X or bring back the trash can.
  • Selection drop down menu is entirely disabled (can't be opened) unless something is selected. When something is selected individual items within the drop down menu may still be disabled. This is a little bit confusing. In addition, "Selection..." is a split combo button, but the left hand part of the button doesn't appear to do anything.
  • "Add data" and "Run a pipeline" modal dialogs are somewhat cramped and confusing, but I'm scheduled to further improve them this sprint.
  • Missing "create a subfolder" button
  • Permissions tab: should switch this page so that "Inherited permissions" is on the left and "Additional permissions" is on the right since the "inherited" permissions are the defaults.
  • The "Move to..." button is in the "Inherited permissions" panel, which is very confusing.
  • Names are not retained when copying between folders:
    1. Go to Compare 2 GATK runs
    2. Select GATK w default params
    3. Go to another folder
    4. Select "Copy selections into this project"
    5. The item will show up with its UUID instead of the name from the origin folder.
  • There is no "Move selections into this project"
  • Discoverability/perceived affordance of the selection mechanism sucks (but this is mostly my fault)

Pipelines

  • I created a new pipeline from template "GATK / exome PE fastq to snp" and arrived at the "easy input page". The easy input page doesn't indicate that any inputs are required, but clicking over to the "Components" tab indicates that bwa-aln shows a required "input" parameter. This seems like a bug.

#5 Updated by Tom Clegg over 6 years ago

Peter Amstutz wrote:

  • For some reason, the page is about 5-10 times wider than the window width, so there is a horizontal scroll off into empty space.
  • My "Recent jobs and pipelines" is empty because it searches for things owned by my projects, but not owned by me directly

Both fixed. (Breadcrumbs CSS still not perfect but at least no h-scroll.)

  • It would be nice if it showed who owned each folder shared with me

A bit tricky until non-admin users are allowed to see other users' names. OK to defer rather than block on that?

  • Pencil icon to rename items within a project should be on the right side of the name for consistency
  • I don't like using a circle with a slash through it to indicate "delete", that icon is most often used to mean "forbidden" (eg "no smoking" "no parking"). Prefer an X or bring back the trash can.
  • Selection drop down menu is entirely disabled (can't be opened) unless something is selected. When something is selected individual items within the drop down menu may still be disabled. This is a little bit confusing. In addition, "Selection..." is a split combo button, but the left hand part of the button doesn't appear to do anything.
  • Missing "create a subfolder" button
  • Permissions tab: should switch this page so that "Inherited permissions" is on the left and "Additional permissions" is on the right since the "inherited" permissions are the defaults.
  • The "Move to..." button is in the "Inherited permissions" panel, which is very confusing.
  • Names are not retained when copying between folders:
    1. Go to Compare 2 GATK runs
    2. Select GATK w default params
    3. Go to another folder
    4. Select "Copy selections into this project"
    5. The item will show up with its UUID instead of the name from the origin folder.
  • There is no "Move selections into this project"

...fixed

  • Discoverability/perceived affordance of the selection mechanism sucks (but this is mostly my fault)
  • "Add data" and "Run a pipeline" modal dialogs are somewhat cramped and confusing, but I'm scheduled to further improve them this sprint.

Agree on both counts. But defer rather than hold things up?

  • I created a new pipeline from template "GATK / exome PE fastq to snp" and arrived at the "easy input page". The easy input page doesn't indicate that any inputs are required, but clicking over to the "Components" tab indicates that bwa-aln shows a required "input" parameter. This seems like a bug.

Haven't managed to reproduce this. An older version on 2872 branch ignored the "optional" flag which caused stuff like this. Looking at old version? Or maybe still a loophole?

#6 Updated by Peter Amstutz over 6 years ago

Dashboard

  • On the "recent jobs and pipelines" table, when I mouse over the job descriptions on the right hand side I get a scroll bar and the panel is able to scroll about 2 pixels. This is odd.
  • The pencil icon for "edit label" is on the left side of the pipeline name
  • Should it say "Projects shared with me" instead of "Shared projects" to be less ambiguous?
  • Upper left nav menu popup shows all folders, not just the top level ones, and doesn't indent to indicate folder nesting.

Folder view

  • The "Selection..." button is still a split button, and the "Selection..." side still doesn't do anything. You can now open the drop down even if nothing is selected, and the menu items will appear disabled, but you can still click on them, which leads you to a crash page.
  • The "Move to..." button should say "Move project..." otherwise it's unclear whether it acts on the project on on the selections.
  • I'm not clear on the exact circumstances to reproduce this, but I should mention it: on a couple occasions I went to delete an item and it did the "wipe" animation part way (the edit icon wipes over the name) but somehow got stuck and never actually removed the row.
  • "Add a subproject" takes me back to the dashboard, and doesn't appear to create a new project anywhere. Huh? I expected this to create a subproject under the current one.
  • All of the buttons/menu items that pop up modal dialogs should have an ellipse (...) to indicate that they require further user interaction.
  • "Run a pipeline" doesn't list all the pipelines in the system, and doesn't preferentially list pipelines that I own (as previously noted, I hope to be working on this bit soon)
  • Semantics of the "delete" button are confusing. Apparently I can only delete an empty project. Instead of hiding the delete button when there are things in the project, it should be shown disabled with a label or tooltip explaining this.

Collections page

  • Under sharing and permissions, qr1hi-o0j2j-2nqnnq1egx3d0o0 is listed as being in "Pete's folder" twice, but only shows up once in the folder contents list.

Pipeline instance

  • The Run button is missing! Apparently this bug is in master. We discussed this in the office the other day and deferred fixing it because we thought your branch would fix it, but instead now it is broken in your branch too!
  • The "easy run pipeline" logic interacts somewhat poorly with the "automatically reload tabs" logic, because the "easy run" only shows the inputs that are unset, and after you set something, it disappears because the tab reloads, so if you wanted to change your mind, whoops!
  • After doing "Clone and edit" the pipeline instance page has no title or description

Everywhere

  • Breadcrumbs are a little confusing. If I'm looking at an item in a folder, I see the folder name, and then the right chevron, and then nothing, unless the item is a subproject, in which case I see the subproject name.

#7 Updated by Tom Clegg over 6 years ago

Peter Amstutz wrote:

  • On the "recent jobs and pipelines" table, when I mouse over the job descriptions on the right hand side I get a scroll bar and the panel is able to scroll about 2 pixels. This is odd.

Hacked this by making the rows taller.

  • The pencil icon for "edit label" is on the left side of the pipeline name
  • Should it say "Projects shared with me" instead of "Shared projects" to be less ambiguous?
  • Upper left nav menu popup shows all folders, not just the top level ones, and doesn't indent to indicate folder nesting.

All fixed. Chose "show nesting" rather than "show only top level".

  • The "Selection..." button is still a split button, and the "Selection..." side still doesn't do anything. You can now open the drop down even if nothing is selected, and the menu items will appear disabled, but you can still click on them, which leads you to a crash page.
  • The "Move to..." button should say "Move project..." otherwise it's unclear whether it acts on the project on on the selections.
  • "Add a subproject" takes me back to the dashboard, and doesn't appear to create a new project anywhere. Huh? I expected this to create a subproject under the current one.
  • All of the buttons/menu items that pop up modal dialogs should have an ellipse (...) to indicate that they require further user interaction.

Fixed.

  • Semantics of the "delete" button are confusing. Apparently I can only delete an empty project. Instead of hiding the delete button when there are things in the project, it should be shown disabled with a label or tooltip explaining this.

Now the delete button is always there, and deleting a project deletes all of its contents (more precisely, sets owner to current_user.uuid, so the items aren't truly deleted, but at least they go away.)

  • "Run a pipeline" doesn't list all the pipelines in the system, and doesn't preferentially list pipelines that I own (as previously noted, I hope to be working on this bit soon)

It does list all pipeline templates, subject to permissions. Filtering and sorting is a separate story, yes. (Have to stop somewhere!)

  • I'm not clear on the exact circumstances to reproduce this, but I should mention it: on a couple occasions I went to delete an item and it did the "wipe" animation part way (the edit icon wipes over the name) but somehow got stuck and never actually removed the row.

Haven't been able to reproduce this yet.

  • Under sharing and permissions, qr1hi-o0j2j-2nqnnq1egx3d0o0 is listed as being in "Pete's folder" twice, but only shows up once in the folder contents list.

Fixed. Assuming this was caused by putting a collection in a folder twice under two different names.

  • The Run button is missing! Apparently this bug is in master. We discussed this in the office the other day and deferred fixing it because we thought your branch would fix it, but instead now it is broken in your branch too!
  • The "easy run pipeline" logic interacts somewhat poorly with the "automatically reload tabs" logic, because the "easy run" only shows the inputs that are unset, and after you set something, it disappears because the tab reloads, so if you wanted to change your mind, whoops!
  • After doing "Clone and edit" the pipeline instance page has no title or description

Fixed. These bugs all come from the ajax-tab-panes branch. It may have also broken other places where partials use content_for to put stuff in tab_line_buttons, footer_js, etc.

If a pipeline template has description/title then that input shows up on the "easy inputs" tab regardless of "required" flag. We could force this issue by declaring it a template-authorship error to make a required input with no description. (First time you try to use your own template, you get no "inputs" tab and you can't run it --> you fix it before sharing your template.)

  • Breadcrumbs are a little confusing. If I'm looking at an item in a folder, I see the folder name, and then the right chevron, and then nothing, unless the item is a subproject, in which case I see the subproject name.

Removed trailing chevron.

55442fc

#8 Updated by Peter Amstutz over 6 years ago

General

  • I keep clicking on the home icon next to Projects in the upper left and expecting to go back to the dashboard. Perhaps the "My projects" menu header should be clickable. It's not obvious that you should click on the upper-left "branding" text (except by convention).
  • Provenance graphs are often much larger and taller than the page, which makes scrolling challenging, this is what the "smart scrolling fixup" was supposed to address, we should put in a bug to get that working again.
  • Styling using panels on some pages (dashboard, collections) but not on others (folder contents, pipelines) feels inconsistent. We can address this later.

Folder contents

Collections page

  • "Create sharing link" fails with a workbench backtrace
  • The "show all projects" button takes me to a links page with a query filter, but uses "?filter=" (missing the 's')
    instead of "?filters=" so it shows all links

Overall: still found a few bugs, but we're almost there :-)

#9 Updated by Tom Clegg over 6 years ago

Peter Amstutz wrote:

  • I keep clicking on the home icon next to Projects in the upper left and expecting to go back to the dashboard. Perhaps the "My projects" menu header should be clickable. It's not obvious that you should click on the upper-left "branding" text (except by convention).

Not tweaking UI widgets any more in this branch. UI guys will tell us what to do (but currently they're waiting to try this branch).

  • Provenance graphs are often much larger and taller than the page, which makes scrolling challenging, this is what the "smart scrolling fixup" was supposed to address, we should put in a bug to get that working again.

Fixed. Had nested smart-scroll, presumably merge fallout.

  • Styling using panels on some pages (dashboard, collections) but not on others (folder contents, pipelines) feels inconsistent. We can address this later.

Right, this branch is not meant to fix everything.

Not holding up the branch for this. UI guy will tell us the right widget.

Yes, bug from #2961. Fixed.

  • When I delete a subproject, it takes me back to the dashboard. For some reason, I was expecting it to redirect me to the parent project.

Fixed.

  • "Create sharing link" fails with a workbench backtrace

WFM. Any more details?

  • The "show all projects" button takes me to a links page with a query filter, but uses "?filter=" (missing the 's')
    instead of "?filters=" so it shows all links

Bug from #2753. Fixed.

Overall: still found a few bugs, but we're almost there :-)

Any more?

62738e6

#10 Updated by Peter Amstutz over 6 years ago

  • The compare page now renders, but rendering the graph fails: /pipeline_instances/compare?uuids[]=qr1hi-d1hrv-m5iwwpk8gl8kfs7&uuids[]=qr1hi-d1hrv-mmkyp110vjb4w8p if this isn't an easy fix, you want to start making bugs and assigning them to me in order to not hold up the merge
  • Smart scroll still not working, for example "Used by" on /collections/qr1hi-o0j2j-2nqnnq1egx3d0o0 don't hold up the merge, make a bug and assign it to me
  • I just tried making a sharing link and it worked, so let's just keep an eye on that.

Let's merge this thing!

#11 Updated by Anonymous over 6 years ago

  • Status changed from New to Resolved
  • % Done changed from 60 to 100

Applied in changeset arvados|commit:cec09589e50ced6d0b7a0d90d5ca124241d4a58a.

Also available in: Atom PDF