Bug #2890

Seed database with empty manifest and world-read permission

Added by Brett Smith over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Start date:
05/28/2014
Due date:
% Done:

0%

Estimated time:
Story points:
0.5

Description

A recent, temporary Keep bug caused a Job to fail to save a log. Showing the Job in Workbench said that the log was the empty block. However, since the PUT failed completely, the user had no permission to see the block. This created a confusing error when the user tried to view the log.

I think it makes sense to seed our database with permission for every to read the empty block, and we should go ahead and do that. Admittedly there are several other bugs at play here too, but I think adding this could help prevent similar bad future situations from becoming worse.

History

#1 Updated by Tom Clegg over 5 years ago

  • Subject changed from Should everyone have read permission for the empty block? to Seed database with empty manifest and world-read permission
  • Story points set to 0.5

#2 Updated by Tom Clegg about 5 years ago

  • Status changed from New to Closed

Closed as duplicate of (more recent) #3072 which offers a different solution.

Also available in: Atom PDF