Project

General

Profile

Actions

Story #3020

closed

[Deployment] Docker installation runs crunch-dispatch and worker nodes

Added by Tom Clegg about 8 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assigned To:
-
Category:
Docker
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
8.0

Description

With a fresh docker install, it should be possible to:
  • Run an example script/pipeline (hash) using Workbench
Optional:
  • Run a job which specifies a container image (i.e., docker-in-docker).
  • Use node manager to bring up worker containers dynamically. (Instead, for now, just start up two worker containers. A fixed number of workers tends to make slurm setup much less painful.)

Related issues

Is duplicate of Arvados - Feature #3219: [Docker] further docker image improvementsResolvedWard Vandewege06/10/2014

Actions
Actions #1

Updated by Tom Clegg about 8 years ago

  • Description updated (diff)
Actions #2

Updated by Tom Clegg about 8 years ago

  • Target version deleted (2014-07-16 Sprint)
Actions #3

Updated by Tom Clegg about 8 years ago

  • Target version set to Arvados Future Sprints
Actions #4

Updated by Tom Clegg about 8 years ago

  • Subject changed from Docker installation runs crunch-dispatch and worker nodes to [Deployment] Docker installation runs crunch-dispatch and worker nodes
Actions #5

Updated by Brett Smith over 7 years ago

  • Category set to Docker
  • Status changed from New to Closed
  • Target version deleted (Arvados Future Sprints)

Done in #3219.

Actions

Also available in: Atom PDF