Project

General

Profile

Actions

Bug #3136

closed

[Crunch] Job state is stale in Workbench pipeline instance views, if the job's state changes after the pipeline instance stops.

Added by Peter Amstutz almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Crunch
Target version:
Story points:
1.0

Description

Steps to reproduce:

  1. Run a pipeline
  2. Hit "Stop". This doesn't actually cancel the running jobs, see Bug #3165
  3. Go to the individual job page and cancel the job.
  4. Since the arv-run-pipeline-instance is no longer updating the copy of the job information in the pipeline instance record (why should it, it's stopped, right?) the pipeline will continue to show the job as running.

Quick resolution:

  • In Workbench, look up each job by UUID instead of rendering the copy of the job record stored in the pipeline instance.

Subtasks 2 (0 open2 closed)

Task #3327: Fix workbench display to only use the actual jobs and ignore denormalized copy of job data in components.ResolvedPeter Amstutz08/25/2014Actions
Task #3676: Review 3136-stale-pipeline-instance-displayResolvedBrett Smith08/25/2014Actions
Actions #1

Updated by Tom Clegg almost 10 years ago

  • Subject changed from Canceled jobs are shown as running in Workbench to Canceled jobs are shown as running in Workbench [where?]
Actions #2

Updated by Peter Amstutz almost 10 years ago

  • Subject changed from Canceled jobs are shown as running in Workbench [where?] to Canceled jobs are shown as still running in Workbench pipeline instance views
Actions #3

Updated by Peter Amstutz almost 10 years ago

  • Description updated (diff)
Actions #4

Updated by Tom Clegg almost 10 years ago

  • Subject changed from Canceled jobs are shown as still running in Workbench pipeline instance views to Job state is stale in Workbench pipeline instance views, if the job's state changes after the pipeline instance stops.
Actions #5

Updated by Tom Clegg almost 10 years ago

  • Story points set to 2.0
Actions #6

Updated by Tom Clegg almost 10 years ago

  • Target version set to 2014-08-06 Sprint
Actions #7

Updated by Radhika Chippada almost 10 years ago

  • Subject changed from Job state is stale in Workbench pipeline instance views, if the job's state changes after the pipeline instance stops. to [Crunch] Job state is stale in Workbench pipeline instance views, if the job's state changes after the pipeline instance stops.
  • Category set to Crunch
Actions #8

Updated by Tom Clegg almost 10 years ago

  • Description updated (diff)
Actions #9

Updated by Tom Clegg almost 10 years ago

  • Story points changed from 2.0 to 1.0
Actions #10

Updated by Tom Clegg almost 10 years ago

  • Assigned To set to Peter Amstutz
Actions #11

Updated by Tom Clegg almost 10 years ago

  • Target version changed from 2014-08-06 Sprint to 2014-08-27 Sprint
Actions #12

Updated by Brett Smith almost 10 years ago

Reviewing the quick Workbench fix at aa0ae05

jobuuids = object.components.select { |cname, c| c[:job] and c[:job][:uuid] }

Since jobuuids gets passed into Job.where, it looks to me like it should be an array, but select will give you a subset of the hash. Should this be object.components.map { … }.compact?

pj[:job] = job[c[:job][:uuid]]

Please check that we actually found a matching job before making this assignment. It's not guaranteed, and if we didn't, the method will crash trying to run nil[:success] a little later.

Thanks.

Actions #13

Updated by Peter Amstutz almost 10 years ago

  • Status changed from New to In Progress
Actions #14

Updated by Brett Smith almost 10 years ago

  • Status changed from In Progress to New
Actions #15

Updated by Anonymous almost 10 years ago

  • Status changed from New to Resolved

Applied in changeset arvados|commit:a17b176ea55dc3820ef1bde4b99cf33c628ffbbe.

Actions

Also available in: Atom PDF