Bug #3160

[Workbench] When copying an unnamed pipeline instance, use a blank name instead of "Copy of unnamed pipeline".

Added by Peter Amstutz almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Radhika Chippada
Category:
Workbench
Target version:
Start date:
07/17/2014
Due date:
% Done:

100%

Estimated time:
(Total: 1.00 h)
Story points:
0.5

Description

I have a pipeline named "Copy of Copy of Copy of Copy of Copy of Copy of Copy of Copy of Copy of unnamed pipeline instance". This isn't very helpful.


Subtasks

Task #3289: Review 3160-copy-unnamed-pipelineResolvedTom Clegg

Associated revisions

Revision a7a6110f
Added by Radhika Chippada almost 6 years ago

closes #3160
Merge branch '3160-copy-unnamed-pipeline'

History

#1 Updated by Peter Amstutz almost 6 years ago

  • Description updated (diff)

#2 Updated by Tom Clegg almost 6 years ago

  • Subject changed from Default pipeline name should be something like "template name run at time ZZZ". Copying a pipeline should just update the timestamp at the end if it has the default name. to When copying an unnamed pipeline instance, use a blank name instead of "Copy of unnamed pipeline".
  • Story points set to 0.5

#3 Updated by Tom Clegg almost 6 years ago

  • Target version set to 2014-08-06 Sprint

#4 Updated by Radhika Chippada almost 6 years ago

  • Subject changed from When copying an unnamed pipeline instance, use a blank name instead of "Copy of unnamed pipeline". to [Workbench] When copying an unnamed pipeline instance, use a blank name instead of "Copy of unnamed pipeline".
  • Category set to Workbench

How about "Copy of UUID - timestamp"?

#5 Updated by Radhika Chippada almost 6 years ago

  • Assigned To set to Radhika Chippada

#6 Updated by Radhika Chippada almost 6 years ago

  • Status changed from New to In Progress

#7 Updated by Tom Clegg almost 6 years ago

Looking at 533d351. It looks like it does fix the bug as reported. But is there a rationale for treating PipelineInstance differently here? Or was that just the first / most noticeable way the bug appeared?

#8 Updated by Tom Clegg almost 6 years ago

At commit: 2815aa5 - looks great

#9 Updated by Radhika Chippada almost 6 years ago

  • Status changed from In Progress to Resolved

Applied in changeset arvados|commit:a7a6110f549ae87f6397b53c6d0292bb0cc2ce04.

Also available in: Atom PDF