Bug #3178

Discovery document does not publish optional parameters "find_or_create", "filters", "minimum_script_version", and "exclude_script_versions" for the Job "create" method.

Added by Peter Amstutz over 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
API
Target version:
Start date:
08/10/2014
Due date:
% Done:

100%

Estimated time:
(Total: 3.00 h)
Story points:
0.5

Description

Because these parameters are not published, you can't use from from the 'arv' command line (and presumably most the rest of the SDK.)


Subtasks

Task #3566: Add missing discovery methodsResolvedTom Clegg

Task #3567: Review 3178-discoverable-parametersResolvedTom Clegg

Associated revisions

Revision 57ee9692
Added by Tom Clegg about 5 years ago

Merge branch '3178-discoverable-parameters' closes #3178

History

#1 Updated by Peter Amstutz over 5 years ago

  • Description updated (diff)

#2 Updated by Tom Clegg over 5 years ago

  • Target version set to Arvados Future Sprints

#3 Updated by Tom Clegg about 5 years ago

  • Target version changed from Arvados Future Sprints to 2014-08-27 Sprint

#4 Updated by Tom Clegg about 5 years ago

  • Story points set to 0.5

#5 Updated by Brett Smith about 5 years ago

  • Assigned To set to Brett Smith

#6 Updated by Brett Smith about 5 years ago

  • Assigned To deleted (Brett Smith)

#7 Updated by Tim Pierce about 5 years ago

  • Category set to API

#8 Updated by Tom Clegg about 5 years ago

  • Assigned To set to Tom Clegg

#9 Updated by Tom Clegg about 5 years ago

  • Status changed from New to In Progress

#10 Updated by Brett Smith about 5 years ago

Reviewing fd38dca

The code looks good, but _setup_requires_parameters seems not to work as intended. When I restart the API server from this branch, those parameters don't appear in the discovery document; only send_notification_email appears for Users#setup. (The new Job#create parameters do appear.) Please take another look, and let me know if you need help to see what I'm seeing.

#11 Updated by Tom Clegg about 5 years ago

Brett Smith wrote:

The code looks good, but _setup_requires_parameters seems not to work as intended. When I restart the API server from this branch, those parameters don't appear in the discovery document; only send_notification_email appears for Users#setup. (The new Job#create parameters do appear.) Please take another look, and let me know if you need help to see what I'm seeing.

Ahem. Found two reasons:
  1. I made an instance method instead of a class method.
  2. There was already a class method there, with send_notification_email but not the other parameters.

So I merged the new content into the existing class method.

Now at 2bec2ba

#12 Updated by Brett Smith about 5 years ago

Tom Clegg wrote:

Now at 2bec2ba

This looks good to merge to me. Thanks.

#13 Updated by Anonymous about 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 33 to 100

Applied in changeset arvados|commit:57ee96926d2d3d315ece3b2cbfb20d0fe01ab912.

Also available in: Atom PDF