Bug #3278

[Crunch] crunch-dispatch should cache ApiClientAuthorizations it creates

Added by Brett Smith over 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assigned To:
-
Category:
Crunch
Target version:
-
Start date:
07/17/2014
Due date:
% Done:

0%

Estimated time:
Story points:
0.5

Description

The current code creates a new token each time it tries to get a node allocation. Creating one per job, and keeping it in memory until the job eventually runs, should suffice.

(Originally reported in #3168.)


Related issues

Is duplicate of Arvados - Bug #4297: [Crunch] crunch-dispatch eats way too much cpuResolved10/27/2014

History

#1 Updated by Ward Vandewege over 5 years ago

  • Subject changed from crunch-dispatch should cache ApiClientAuthorizations it creates to [Crunch] crunch-dispatch should cache ApiClientAuthorizations it creates

#2 Updated by Tom Clegg over 5 years ago

  • Category set to Crunch

#3 Updated by Tom Clegg over 5 years ago

  • Story points set to 0.5

#4 Updated by Brett Smith about 5 years ago

  • Status changed from New to Closed
  • Target version deleted (Arvados Future Sprints)

Work done as part of #4297.

Also available in: Atom PDF