Story #3362

[SDKs] Notify user if client library version is much older than server

Added by Radhika Chippada over 6 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
1.0

Description

Implementation
  • Add discovery document key sourceVersionTimestamp
  • Add something similar in SDK (??)
Notes
  • sourceVersionTimestamp will also help clever clients decide "do X if server is new enough to have feature X, otherwise do Y"

Related issues

Related to Arvados - Feature #3964: [SDKs] Command-line diagnostic suite reveals problems on a shell VM (e.g., arv-mount, SDK version skew)New

Related to Arvados - Story #4308: [API] [SDKs] Enable API versioningClosed

Copied to Arvados - Story #10849: [API] [SDKs] When client and server versions differ, the server must either implement the API the client expects, or return an error.New01/09/2017

History

#1 Updated by Radhika Chippada over 6 years ago

  • Target version set to Arvados Future Sprints

#2 Updated by Tom Clegg about 6 years ago

  • Subject changed from [SDK] Notify user if client library is much older than server to [SDKs] Notify user if client library version is much older than server

#3 Updated by Tom Clegg about 6 years ago

  • Description updated (diff)

#4 Updated by Tom Clegg almost 4 years ago

  • Status changed from New to Closed

#5 Updated by Tom Morris almost 4 years ago

  • Target version deleted (Arvados Future Sprints)

Also available in: Atom PDF