Bug #3441

[SDKs] arv-put (if not in debug mode) should not print an error message when it gets "503 full" from a server, if it turns out that the block eventually gets written successfully to different servers.

Added by Abram Connelly about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
SDKs
Target version:
Start date:
07/31/2014
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
0.5

Description

From lightning-dev, uploading a roughly 1Gb file caused the following issue:

$ arv keep put tile_md5sum_hu154_sort.csv.gz
arv-put: No --project-uuid or --name specified.  This data will be cached
in Keep.  You will need to find this upload by its locator(s) later.
576M / 960M 60.0% WARNING:root:Request fail: PUT http://keep0.qr1hi.arvadosapi.com:25107/c4740c5f1d3e0ea358248d7c8de6a26e => 503 Full

640M / 960M 66.6% ^@WARNING:root:Request fail: PUT http://keep0.qr1hi.arvadosapi.com:25107/4ea95e5efec1e50910e7a5d8b9ed9998 => 503 Full

960M / 960M 99.9% WARNING:root:Request fail: PUT http://keep0.qr1hi.arvadosapi.com:25107/2472718df1359de20ab6c6ca6ddb8e5f => 503 Full

960M / 960M 100.0%
WARNING:root:Request fail: PUT http://keep0.qr1hi.arvadosapi.com:25107/fc31c655bcc3fc4538b7b29485bef016 => 503 Full

fc31c655bcc3fc4538b7b29485bef016+715

From talking with the engineering team, it looks like this was caused by a client side issue rather than the keep server actually being full.


Subtasks

Task #3510: Fix warningsResolvedPeter Amstutz

Task #3614: Review 3441-python-keep-log-levelResolvedPeter Amstutz

Associated revisions

Revision 2077dacc
Added by Peter Amstutz about 5 years ago

Merge branch '3441-python-keep-log-level' refs #3441

History

#1 Updated by Peter Amstutz about 5 years ago

So, one of the Keep server disks is actually full. However, I suspect it is actually the case that it is successfully uploading the collection to other Keep servers which have space, but printing misleading warnings messages giving the impression that there is a problem.

#2 Updated by Tom Clegg about 5 years ago

  • Subject changed from arv keep put returning "503 Full" when it shouldn't be? to [SDKs] arv-put (if not in debug mode) should not print an error message when it gets "503 full" from a server, if it turns out that the block eventually gets written successfully to different servers.
  • Story points set to 0.5

#3 Updated by Tom Clegg about 5 years ago

  • Target version set to 2014-08-27 Sprint

#4 Updated by Tim Pierce about 5 years ago

  • Category set to SDKs

#5 Updated by Peter Amstutz about 5 years ago

  • Assigned To set to Peter Amstutz

#6 Updated by Brett Smith about 5 years ago

Reviewing cd5fd13

I would consider promoting the message "Request fail: GET %s => %s: %s" from info to warning, or even error. It represents total failure to complete the request, and it's the only indication the user gets as to why that happened, so being louder seems appropriate.

All the other changes look good to me. Thanks.

#7 Updated by Tom Clegg about 5 years ago

  • Status changed from New to In Progress

#8 Updated by Tom Clegg about 5 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF