Project

General

Profile

Actions

Bug #3486

closed

[DRAFT] [Crunch] Cannot have script parameter value of "false" because arv-run-pipeline-instance (and also workbench) don't distinguish between "false" and "nil"

Added by Peter Amstutz about 8 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
1.0

Description

Perhaps give warning or error when someone uses the ambiguous parameter form.

Bad:
  • "script_parameters":{"foo":false}
    
Good:
  • "script_parameters":{"foo":{"value":false}}
    

Related issues

Related to Arvados - Story #9031: [SDKs] arv-run-pipeline-instance accepts json objects/arrays as script parameter valuesClosed

Actions
Actions #1

Updated by Ward Vandewege about 8 years ago

  • Target version set to Arvados Future Sprints
Actions #2

Updated by Ward Vandewege about 8 years ago

  • Subject changed from Cannot have script parameter value of "false" because arv-run-pipeline-instance (and also workbench) don't distinguish between "false" and "nil" to [Crunch] Cannot have script parameter value of "false" because arv-run-pipeline-instance (and also workbench) don't distinguish between "false" and "nil"
Actions #3

Updated by Tom Clegg about 8 years ago

  • Story points set to 0.5
Actions #4

Updated by Tom Clegg almost 8 years ago

  • Subject changed from [Crunch] Cannot have script parameter value of "false" because arv-run-pipeline-instance (and also workbench) don't distinguish between "false" and "nil" to [Crunch] [obsolete?] Cannot have script parameter value of "false" because arv-run-pipeline-instance (and also workbench) don't distinguish between "false" and "nil"
Actions #5

Updated by Tom Clegg almost 8 years ago

  • Subject changed from [Crunch] [obsolete?] Cannot have script parameter value of "false" because arv-run-pipeline-instance (and also workbench) don't distinguish between "false" and "nil" to [DRAFT] [Crunch] Cannot have script parameter value of "false" because arv-run-pipeline-instance (and also workbench) don't distinguish between "false" and "nil"
  • Description updated (diff)
  • Story points changed from 0.5 to 1.0

Check whether this can be resolved like so:

script_parameters:
  foo:
    value: false
Actions #7

Updated by Tom Clegg almost 6 years ago

3486-parameter-value-nil-or-false

test cece10f069d022925dbcf55835f66d14c39c2788

No testing yet.

Actions #8

Updated by Peter Amstutz almost 6 years ago

  • Status changed from New to Resolved
  • Target version changed from Arvados Future Sprints to 2016-10-26 sprint

This seems to be working as intended, and is merged, so I'm marking resolved.

Actions #9

Updated by Peter Amstutz almost 6 years ago

  • Assigned To set to Tom Clegg
Actions

Also available in: Atom PDF