Bug #3489

[Workbench] Collection chooser starts at "All projects" but doesn't show any collections.

Added by Peter Amstutz about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Workbench
Target version:
Start date:
08/08/2014
Due date:
% Done:

100%

Estimated time:
(Total: 3.00 h)
Story points:
0.5

Subtasks

Task #3539: Reproduce problemResolvedTom Clegg

Task #3544: Indicate preselected project (if any) in chooser instead of always showing "All projects" at firstResolvedTom Clegg

Task #3545: Review 3489-indicate-initial-project-filterResolvedTom Clegg

Associated revisions

Revision c6210b84 (diff)
Added by Tom Clegg about 5 years ago

Fix excessive API calls in collection chooser. refs #3489

Revision a6010696
Added by Tom Clegg about 5 years ago

Merge branch '3489-indicate-initial-project-filter' closes #3489

History

#1 Updated by Peter Amstutz about 5 years ago

  • Category set to Workbench

#2 Updated by Tom Clegg about 5 years ago

  • Assigned To set to Tom Clegg
  • Target version set to 2014-08-27 Sprint

#3 Updated by Tom Clegg about 5 years ago

  • Story points set to 0.5

#4 Updated by Tom Clegg about 5 years ago

  • Status changed from New to In Progress

#5 Updated by Brett Smith about 5 years ago

Reviewing b79c440

  • Group.find?(val).name will crash if it fails to find something, since it ends up calling nil.name. I think this should be Group.find(val).name rescue "Group Projects" (or some other default).
  • The comment with @filters.inspect is effectively a debug statement that should be removed. :)
  • Can we write a test for this?

#6 Updated by Tom Clegg about 5 years ago

Brett Smith wrote:

  • Group.find?(val).name will crash if it fails to find something, since it ends up calling nil.name. I think this should be Group.find(val).name rescue "Group Projects" (or some other default).

Used find(val).name rescue val -- i.e., if the project became unfindable then you just see its UUID.

  • The comment with @filters.inspect is effectively a debug statement that should be removed. :)

Indeed. Removed.

  • Can we write a test for this?

Indeed. Added an assert_selector in the pipeline_instances megatest.

Now at aa923c9

#7 Updated by Brett Smith about 5 years ago

I think aa923c9 is good to merge. Thanks.

#8 Updated by Anonymous about 5 years ago

  • Status changed from In Progress to Resolved

Applied in changeset arvados|commit:a6010696b246cc43c721a35d56179c629d54e798.

Also available in: Atom PDF