Story #3499

[Workbench] Objects owned directly by user are visible on a "home" project

Added by Peter Amstutz about 5 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Workbench
Target version:
Start date:
08/06/2014
Due date:
% Done:

100%

Estimated time:
(Total: 13.00 h)
Story points:
1.0

Description

Provide a "Home" project page that shows objects with owner_uuid == current_user.uuid. This allows the user to find collections, jobs, etc that were created but not assigned to a project.

Breadcrumbs will look something like: "Dashboard >> Projects >> Home >> ExampleProjectXYZ"


Subtasks

Task #3516: Update docsResolvedRadhika Chippada

Task #3514: Make groups/{user_uuid}/contents return home project contentsResolvedTom Clegg

Task #3513: Update breadcrumbs to show Home link to projects/user_uuidResolvedTom Clegg

Task #3515: Make projects#show page behave properly when uuid is a user_uuidResolvedTom Clegg

Task #3517: Show Home at root of projects treeResolvedTom Clegg

Task #3524: Review 3499-home-projectResolvedPeter Amstutz

Task #3518: arv-put: allow --name without --project-uuid, make up a name if none givenResolvedTom Clegg

Task #3611: Review 3499-home-project-docs-wipResolvedBrett Smith

Associated revisions

Revision da85b5f1
Added by Tom Clegg about 5 years ago

Merge branch '3499-home-project' closes #3499

Revision 35a3223e
Added by Brett Smith about 5 years ago

Merge branch '3499-home-project-docs-wip'

Closes #3516. Refs #3499.

History

#1 Updated by Tom Clegg about 5 years ago

  • Story points set to 1.0

#2 Updated by Peter Amstutz about 5 years ago

  • Subject changed from Objects owned directly by user are visible on a "home" project to [Workbench] Objects owned directly by user are visible on a "home" project
  • Description updated (diff)
  • Category set to Workbench

#3 Updated by Tom Clegg about 5 years ago

  • Description updated (diff)

#4 Updated by Tom Clegg about 5 years ago

  • Description updated (diff)

#5 Updated by Tom Clegg about 5 years ago

  • Assigned To set to Tom Clegg

#6 Updated by Tom Clegg about 5 years ago

  • Status changed from New to In Progress

#7 Updated by Peter Amstutz about 5 years ago

  • arv-put finally puts the file in a reasonable place. Very exciting!
  • The "Move project" and "Delete project" buttons are visible and enabled on the home project page. They should be disabled or invisible.
  • The breadcrumbs bar is the same if you are on the Home project or the Dashboard. It would be nice if there were some visual cue to indicate which of those pages you are actually on.
FAIL: test_KeepBasicRWTest (test_keep_client.KeepPermissionTestCase)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/peter/work/arvados/sdk/python/tests/test_keep_client.py", line 119, in test_KeepBasicRWTest
    unsigned_bar_locator)
AssertionError: NotFoundError not raised

#8 Updated by Tom Clegg about 5 years ago

Peter Amstutz wrote:

  • The "Move project" and "Delete project" buttons are visible and enabled on the home project page. They should be disabled or invisible.

Right, fixed (by removing). Also removed "Sharing" tab, thinking sharing your entire account is something we should deliberately not provide an easy method for. (Is this reasonable?)

  • The breadcrumbs bar is the same if you are on the Home project or the Dashboard. It would be nice if there were some visual cue to indicate which of those pages you are actually on.

Fixed. Also added "Home" to the "My projects" panel on Dashboard.

[...]

Haven't been able to reproduce that failed test.

Now at 1076b57

#9 Updated by Peter Amstutz about 5 years ago

  • Move/Delete buttons are fixed.
  • Breadcrumbs are fixed
  • I tested the "Add data" and "New subproject" buttons and they seem to work as expected
  • I went to "run a pipeline" and got this box:

Hey. This pipeline instance belongs to your account, but it's not in any of your projects. If you want it to be easy to find in the future, you should move it to a project.

I think we can safely get rid of this warning now.
  • We talked about having links (except for name and permission) show up under "Other objects", are we going to do that?

#10 Updated by Tom Clegg about 5 years ago

Peter Amstutz wrote:

Hey. This pipeline instance belongs to your account, but it's not in any of your projects. If you want it to be easy to find in the future, you should move it to a project.

I think we can safely get rid of this warning now.

Indeed. Removed.

  • We talked about having links (except for name and permission) show up under "Other objects", are we going to do that?

Possibly, but surely not as part of this story.

#11 Updated by Anonymous about 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 69 to 100

Applied in changeset arvados|commit:da85b5f1617656e03535dc490f027d7fae4d702e.

#12 Updated by Radhika Chippada about 5 years ago

Review feed back for the 3499-doc branch:

1. api-tokens.html.textile.liquid

In the sentence “Click on the link with your email address in the upper right corner to access the user settings menu” — We call our “gear” menu as “settings menu”. It is better to say “My account” menu, since we now have that name in this drop down menu.

2. tutorial-keep.html.textile.liquid

- “To move the collection to a specific project” — how about “To move the collection to a different project”?

- I think it would be nice if you add a picture of the “move selected” button

3. tutorial-pipeline-workbench.html.textile.liquid

- There are a couple of typos in the first paragraph (you did not update it, but since you are updating this page anyways :)

A “pipeline” . . . is sequence of - - it is better to say “is a sequence of” (missing the word “a”)

“small data set of paired-end reads from an sample” - - should be “from a sample” (used “an” instead of “a”)

- “You can return to the Dashboard by clicking on” - - how about “You can go to . . . ” or “You can access the Dashboard . . . “

- “On the My projects panel” - - I think “In the My projects panel” would be better

- “This will direct you to the page for the new project.” - - Can we say “This will create a new project and take you to the page for the new project”?

- “to the right of the SAM file download your results” - - “to the right of the SAM file to download your results” (missing the word “to”)

- “Click on <span class="btn btn-sm btn-primary" >Run <i class="fa fa-fw fa-play"></i></span>” - - This looks pretty odd without the word “ button” after the Run button.

- Can you please add the word button or drop down or whatever after all the span elements. I copied a few more occurrences below.

“Click on <span class="btn btn-sm btn-primary"><i class="fa fa-fw fa-gear"></i> Run a pipeline...</span>” - - how about adding the word “button” after this

“Click on All projects <span class="caret"></span>” - - how about adding “drop down” after this

“Under the Projects shared with me header, select <i class="fa fa-fw fa-share-alt"></i> Arvados Tutorial” - - how about adding the word “project” after this

#13 Updated by Brett Smith about 5 years ago

Radhika,

All these suggestions are great. I've pushed a new commit to incorporate everything you suggested.

Radhika Chippada wrote:

- “This will direct you to the page for the new project.” - - Can we say “This will create a new project and take you to the page for the new project”?

I did use a different sentence here because I thought it sounded awkward to repeat "project" so often, but I hope the change follows the flow of your suggestion.

Ready for another look at 8402746. Thanks.

#14 Updated by Radhika Chippada about 5 years ago

Brett, everything looks great now, but for the one concern below.

- In the newly added selection image "workbench-move-selected.png", I think it would be most helpful to the users if you were to include the tabs also. I think the user needs to see "Data collections" tab (and those that fit in within the dropdown area) to know right away where the Selection dropdown is located.

After that, everything LGTM. thanks.

#15 Updated by Brett Smith about 5 years ago

Radhika Chippada wrote:

- In the newly added selection image "workbench-move-selected.png", I think it would be most helpful to the users if you were to include the tabs also. I think the user needs to see "Data collections" tab (and those that fit in within the dropdown area) to know right away where the Selection dropdown is located.

That sounds good too. The new commit is 35a3223 and merged with master. Thanks again.

Also available in: Atom PDF