Feature #3805

[SDKs] CLI supports ARVADOS_CONFIG variable

Added by Tim Pierce about 5 years ago. Updated over 3 years ago.

Status:
Duplicate
Priority:
Normal
Assigned To:
-
Category:
SDKs
Target version:
-
Start date:
09/03/2014
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

If a user has a file $HOME/.config/arvados/foobar.conf with Arvados environment variable settings, e.g.:

$ cat $HOME/.config/arvados/foobar.conf
ARVADOS_API_HOST=blahblah.arvadosapi.com
ARVADOS_API_HOST_INSECURE=yes
ARVADOS_API_TOKEN=5tsb2pc3zlatn1ortl98s2tqsehpby88wmmnzmpsjmzwa6payh

... then the single ARVADOS_CONFIG environment variable should be sufficient to configure an API client:

ARVADOS_CONFIG=foobar arv-get f00ba-4zz18-t68oksiu9m80s4y

Related issues

Is duplicate of Arvados - Story #3897: [SDKs] Clients can specify which auth config file to load.New

History

#1 Updated by Brett Smith almost 5 years ago

  • Subject changed from CLI supports ARVADOS_CONFIG variable to [SDKs] CLI supports ARVADOS_CONFIG variable

#2 Updated by Brett Smith over 3 years ago

  • Status changed from New to Duplicate

Duplicates #3897. (This came first, but #3897 has more grooming.)

Also available in: Atom PDF