Bug #3847

[SDK] --project-uuid switch behaves strangely without = (seen in arv-keepdocker, arv-copy)

Added by Sarah Guthrie over 2 years ago. Updated 3 months ago.

Status:ResolvedStart date:09/10/2014
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:SDKs
Target version:-
Story points0.5
Velocity based estimate-

Description

$ arv keep docker --project-uuid qr1hi-j7d0g-593lq8oed0gymt3 --name "Docker image with crunch user" 76ca48f2d705
arv-keepdocker: error: argument --project-uuid: expected one argument

$ arv keep docker --project-uuid=qr1hi-j7d0g-593lq8oed0gymt3 --name "Docker image with crunch user" 76ca48f2d705
arv-keepdocker: error: argument --name: expected one argument

$ arv keep docker --project-uuid=qr1hi-j7d0g-593lq8oed0gymt3 --name="Docker image with crunch user" 76ca48f2d705
[runs successfully]


Related issues

Duplicated by Arvados - Bug #6305: [SDK] arv keep docker argument parsing is too sensitive/w... Duplicate

History

#1 Updated by Brett Smith over 2 years ago

  • Subject changed from arv keep docker argument parses unexpectedly to [SDK] arv-put --project-uuid switch behaves strangely without =
  • Category set to SDKs

#2 Updated by Tom Clegg over 2 years ago

  • Subject changed from [SDK] arv-put --project-uuid switch behaves strangely without = to [SDK] arv keep docker --project-uuid switch behaves strangely without =

#3 Updated by Tom Clegg over 2 years ago

  • Story points set to 0.5

#4 Updated by Tom Clegg over 2 years ago

  • Target version set to Arvados Future Sprints

#5 Updated by Brett Smith almost 2 years ago

  • Subject changed from [SDK] arv keep docker --project-uuid switch behaves strangely without = to [SDK] --project-uuid switch behaves strangely without = (seen in arv-keepdocker, arv-copy)

#6 Updated by Brett Smith 11 months ago

What happens is arv parses its own switches, then looks for a subcommand, then calls the subcommand with whatever switches remain. I'm starting to suspect this is caused by how arv parses out switches it doesn't know about.

#7 Updated by Tom Clegg 3 months ago

  • Status changed from New to Resolved

Seems to have been fixed, although I don't see where/when.

$ arv --version
/usr/local/rvm/gems/ruby-2.3.3/gems/arvados-cli-0.1.20170306153140/bin/arv
$ gem list | grep trollop
trollop (2.1.2)
$ arv keep docker --project-uuid "foo" --name "foo bar" | tail -n1
arvados/jobs                    latest      a554b2b52870  4xphq-4zz18-3o6rl3naxk9wz85    Fri Jun 27 19:20:35 2014

#8 Updated by Tom Clegg 3 months ago

  • Target version deleted (Arvados Future Sprints)

Also available in: Atom PDF