Bug #3890

[API] dots (and probably other valid characters) are being stripped from git repository names. The name field in the output of arv repository get_all_permissions is wrong (it strips characters that are valid)

Added by Ward Vandewege almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
0.5

History

#1 Updated by Ward Vandewege almost 5 years ago

  • Subject changed from dots (and probably other valid characters) are being stripped from git repository names. The name field in the output of arv repository get_all_permissions is wrong (it strips characters that are valid) to [API] dots (and probably other valid characters) are being stripped from git repository names. The name field in the output of arv repository get_all_permissions is wrong (it strips characters that are valid)

#2 Updated by Ward Vandewege almost 5 years ago

  • Target version changed from Bug Triage to Arvados Future Sprints

#3 Updated by Tom Clegg almost 5 years ago

This works for me:

  1. Gear menu → Users
  2. Add new user
  3. email test.case@example.com, username "test.case", shell VM, OK
  4. workbench/repositories lists repo name="test.case"
  5. arv repositories get_all_permissions lists name="test.case"
  {
   "uuid":"4xphq-s0uqq-mv6frei5ignh690",
   "name":"test.case",
   "push_url":"git@git.4xphq.arvadosapi.com:test.case.git",
   "fetch_url":"git@git.4xphq.arvadosapi.com:test.case.git",

#4 Updated by Ward Vandewege almost 5 years ago

  • Status changed from New to Resolved
  • Target version changed from Arvados Future Sprints to 2014-10-08 sprint

Found and fixed by making a change in the update-gitolite.rb script.

Also available in: Atom PDF