Feature #4051

[Workbench] Pipeline component display order should be controlled by sort_order attributes if present.

Added by Peter Amstutz almost 5 years ago. Updated almost 5 years ago.

Status:
Rejected
Priority:
Normal
Assigned To:
-
Category:
-
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
0.5

Description

Pipeline components are stored in a hash. In Ruby, and in the YAML representation of components that is stored in the database, the ordering of hash keys is consistent. However, when the components are handled by other languages such as Python (for example, by arv-copy) the order of components is likely to get permuted because order is not guaranteed by json or for "dict" or "hash" types by the in most languages.

A fix to display the components with consistent ordering was implemented way back in March in ac2db7d4aa32a772d9f21db3f1a8a63b1ad0ca2f and reverted in April with 085e614c8e7d1a29e675cf839a1ce9d92ffc5d5c


Related issues

Is duplicate of Arvados - Story #2992: [Workbench] Support "display_order" (integer) key for pipeline template components. Obey when rendering pipeline summary/details in Workbench.Rejected03/13/2019

History

#1 Updated by Peter Amstutz almost 5 years ago

  • Description updated (diff)

#2 Updated by Peter Amstutz almost 5 years ago

If it's really important that users be able to customize the sort order, we could add a sort-order field that takes precedence over a default sorting policy of topological+lexical sorting.

#3 Updated by Tom Clegg almost 5 years ago

  • Tracker changed from Bug to Feature
  • Subject changed from Order of pipeline components is not consistent to [Workbench] Pipeline component display order should be controlled by sort_order attributes if present.

#4 Updated by Tom Clegg almost 5 years ago

  • Story points set to 0.5

#5 Updated by Tom Clegg almost 5 years ago

  • Target version changed from Bug Triage to Arvados Future Sprints

#6 Updated by Peter Amstutz almost 5 years ago

  • Status changed from New to Rejected

Duplicate. Moved over to #2992

#7 Updated by Ward Vandewege almost 5 years ago

  • Target version changed from Arvados Future Sprints to 2014-10-29 sprint

Also available in: Atom PDF