Bug #4064

[Crunch] Typoed "output_of" value in pipeline leaves a job stuck in the queue

Added by Bryan Cosca almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
-
Category:
Crunch
Target version:
Start date:
10/09/2014
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
0.5

Description

I had a typo in one of my inputs to one of my jobs, specifically my parameter was "output_of":"conbine_xxxx" (instead of combine). When I went to rerun my pipeline, the job would say "Not Ready" and would not run. The logs also did not say I had a typo, which would be nice to see that it wasn't able to find that input. Also, when I fixed the typo, the job would not run, I'm guessing because the pipelines were still in queue but wouldn't run but were still trying to run and thus, taking up the node slots. After pausing those pipelines (I wish I could cancel them but I didn't have that option (it would be cool to cancel queued jobs)), then my job could run.


Subtasks

Task #4171: [Crunch] arv-run-pipeline-instance should detect bad "output_of" values and fail the pipelineClosed


Related issues

Is duplicate of Arvados - Bug #3698: [Crunch] Pipeline runner should detect when "output_of" refers to a non-existent component, and fail instead of staying in RunningOnServer state forever.Resolved10/17/2014

History

#1 Updated by Ward Vandewege almost 5 years ago

  • Target version set to Bug Triage

#2 Updated by Radhika Chippada almost 5 years ago

  • Subject changed from Typo in pipeline template input makes the job stuck in queue to [Crunch] Typo in pipeline template input makes the job stuck in queue
  • Category set to Crunch

#3 Updated by Brett Smith almost 5 years ago

  • Subject changed from [Crunch] Typo in pipeline template input makes the job stuck in queue to [Crunch] Typoed "output_of" value in pipeline leaves a job stuck in the queue

#4 Updated by Brett Smith almost 5 years ago

I broke the different components of this report into individual tasks.

#5 Updated by Brett Smith almost 5 years ago

  • Target version changed from Bug Triage to Arvados Future Sprints

#6 Updated by Peter Amstutz almost 5 years ago

  • Status changed from New to Resolved

Fixed in #3698

#7 Updated by Ward Vandewege almost 5 years ago

  • Target version changed from Arvados Future Sprints to 2014-10-29 sprint

#8 Updated by Ward Vandewege almost 5 years ago

  • Story points set to 0.5

Also available in: Atom PDF