Bug #4068

[Workbench] the /manage_account account page does not show all repositories a user has access to

Added by Ward Vandewege about 5 years ago. Updated about 5 years ago.

Status:
Rejected
Priority:
Normal
Assigned To:
Radhika Chippada
Category:
Workbench
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Story points:
0.5

Description

For example, user qr1hi-tpzed-rv6f0l8lbvdzkog can not see their own repository on the manage account page, only a repository someone else gave them access to.

History

#1 Updated by Ward Vandewege about 5 years ago

  • Description updated (diff)
  • Story points set to 0.5

#2 Updated by Ward Vandewege about 5 years ago

  • Category set to Workbench

#3 Updated by Ward Vandewege about 5 years ago

  • Target version changed from Bug Triage to Arvados Future Sprints

#4 Updated by Ward Vandewege about 5 years ago

  • Target version changed from Arvados Future Sprints to 2014-10-29 sprint

#5 Updated by Radhika Chippada about 5 years ago

  • Assigned To set to Radhika Chippada

#6 Updated by Radhika Chippada about 5 years ago

  • Status changed from New to In Progress

#7 Updated by Radhika Chippada about 5 years ago

  • Status changed from In Progress to Feedback
  • Assigned To changed from Radhika Chippada to Ward Vandewege

Ward, you were probably referring to the repository: https://workbench.qr1hi.arvadosapi.com/repositories/qr1hi-s0uqq-i0nso64q89yuh9i

If you access the Advanced tab -> Metadata for this repository, you will notice that the tail_uuid is pointing to a different user account for Bryan: https://workbench.qr1hi.arvadosapi.com/users/qr1hi-tpzed-iygpm2vfsljmx3u

This is hence not accessible to the user you listed in the ticket.

Hence, please let me know if I mark this issue as "Rejected" with this explanation. Thanks.

#8 Updated by Radhika Chippada about 5 years ago

  • Assigned To changed from Ward Vandewege to Radhika Chippada

#9 Updated by Radhika Chippada about 5 years ago

  • Status changed from Feedback to Rejected

Rejecting since it is not a bug.

Also available in: Atom PDF