Bug #4200

[Crunch] Notify user, cancel pipeline when it cannot run because a parameter is the output_of a nonexistent component

Added by Brett Smith almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assigned To:
-
Category:
Crunch
Target version:
Start date:
10/15/2014
Due date:
% Done:

0%

Estimated time:
Story points:
0.5

Description

This error case should be logged and mark the pipeline as failed, like other cases of unrunnable pipelines.


Related issues

Is duplicate of Arvados - Bug #3698: [Crunch] Pipeline runner should detect when "output_of" refers to a non-existent component, and fail instead of staying in RunningOnServer state forever.Resolved10/17/2014

History

#1 Updated by Brett Smith almost 5 years ago

  • Subject changed from [Crunch] No log output when a pipeline cannot run because a parameter is the output_of a nonexistent component to [Crunch] Notify user, cancel pipeline when it cannot run because a parameter is the output_of a nonexistent component

#2 Updated by Ward Vandewege almost 5 years ago

  • Target version changed from Bug Triage to Arvados Future Sprints

#3 Updated by Ward Vandewege almost 5 years ago

  • Story points set to 0.5

#4 Updated by Brett Smith almost 5 years ago

  • Status changed from New to Closed
  • Target version changed from Arvados Future Sprints to 2014-10-29 sprint

Also available in: Atom PDF