Bug #4239

[SDKs] Python SDK doesn't work with apiclient 1.3

Added by Brett Smith almost 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Brett Smith
Category:
SDKs
Target version:
Start date:
10/17/2014
Due date:
% Done:

100%

Estimated time:
Story points:
0.5

Description

When you try to test the current SDK with apiclient 1.3 installed, the tests don't even run. See a failed build log.

It would be good to investigate and resolve this, so we don't get stuck on an unmaintained version.

Associated revisions

Revision 95f99e05 (diff)
Added by Brett Smith almost 5 years ago

4239: Update Python SDK for google-api-python-client 1.3.

This package renames the module from apiclient to googleapiclient. It
provides a shim apiclient module for compatibility, but it only
exports the appropriate names, not real submodules. Using it requires
changing imports like

import apiclient.errors

to

from apiclient import errors

This approach works (has been tested) with both versions 1.2 and 1.3.
Closes #4239.

Revision 8d7ac593 (diff)
Added by Brett Smith almost 5 years ago

4239: Build more dependencies of new google-api-python-client.

Refs #4239.

Revision 8d7ac593 (diff)
Added by Brett Smith almost 5 years ago

4239: Build more dependencies of new google-api-python-client.

Refs #4239.

History

#1 Updated by Brett Smith almost 5 years ago

  • Status changed from New to In Progress
  • Assigned To set to Brett Smith

#2 Updated by Brett Smith almost 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Applied in changeset arvados|commit:95f99e05352e2a87ad627a0b4c775f7551ef9265.

#3 Updated by Ward Vandewege almost 5 years ago

  • Target version changed from Bug Triage to 2014-10-29 sprint

#4 Updated by Ward Vandewege almost 5 years ago

  • Story points set to 0.5

Also available in: Atom PDF