Bug #4476

[Workbench] Search dialog infinite scrolling issue: second page and onwards do not filter out items and search filter is ignored.

Added by Radhika Chippada almost 7 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Radhika Chippada
Category:
Workbench
Target version:
Start date:
12/11/2014
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
0.5

Subtasks

Task #4803: Review branch: 4476-search-next-page-issueResolvedPeter Amstutz


Related issues

Related to Arvados - Feature #4024: [Workbench] PipelineInstances#index should scroll down to show older pipelines, and should have a search box (similar to the "pipelines" tab on the "show project" page)Resolved10/28/2014

Associated revisions

Revision 6e396b29
Added by Radhika Chippada almost 7 years ago

closes #4476
closes #4804
Merge branch '4476-search-next-page-issue'

History

#1 Updated by Tom Clegg almost 7 years ago

  • Subject changed from [Workbench] Search dialog infinite scrolling issue: second page and onwards do not filter out items and search filter is ignored. to [Workbench] Search dialog infinite scrolling issue: second page and onwards do not filter out items and search filter is ignored.
  • Story points set to 0.5

#2 Updated by Tom Clegg almost 7 years ago

This is likely a duplicate of a bug noticed and fixed in #4024.

#3 Updated by Tom Clegg almost 7 years ago

  • Category set to Workbench

#4 Updated by Tom Clegg almost 7 years ago

  • Status changed from New to In Progress

#5 Updated by Radhika Chippada almost 7 years ago

  • Assigned To set to Radhika Chippada
  • Target version changed from Bug Triage to 2015-01-07 sprint

#6 Updated by Radhika Chippada almost 7 years ago

Just one line change. I had much difficulty writing the test (to scroll within search box) and so i gave up.

I manually verified by creating >200 humans in my local api server and then searching for "-7a9it-"

It is not really easy / possible to test pointing to qr1hi because of still unresolved #4523.

I did want to make it easy for the reviewer to test it by creating more than 200 objects in one of projects (qr1hi-j7d0g-1jc55y5dxmhdtbq) named "Radhika Test folder with more than 200 objects", but identified yet another bug #4804.

So, the only effective way to test the fix is by creating more than 200 objects of any type (humans in my case) and searching for the object type portion of the uuid.

#7 Updated by Radhika Chippada almost 7 years ago

Added fix for #4804 in this branch.

To test the fix:

  • Point workbench to qr1hi
  • Click search icon in topnav
  • Select "Radhika Test folder with more than 200 objects" project (uuid qr1hi-j7d0g-1jc55y5dxmhdtbq)
  • Enter string "-4zz18-" in the search box
  • You should see spinner when you scroll down and the scrolling is "finite" and you only see two or so pages worth of data.

#8 Updated by Peter Amstutz almost 7 years ago

LGTM

#9 Updated by Radhika Chippada almost 7 years ago

  • Status changed from In Progress to Resolved

Applied in changeset arvados|commit:6e396b2923990f950bddb427fdf2258eba4b5adf.

Also available in: Atom PDF