Bug #4515

[Workbench] Oops when selecting empty project in chooser

Added by Peter Amstutz almost 7 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Category:
Workbench
Target version:
Start date:
12/16/2014
Due date:
% Done:

100%

Estimated time:
(Total: 3.00 h)
Story points:
0.5

Description

Go to dashboard. Click on "Run pipeline". Under "Projects", select a project that is empty. The chooser will show a "Oops request failed" instead of an empty list.

(Arguably it's unhelpful to show empty projects in the list in the first place, but that's a different story. #4516 to be precise)

This looks like a bug introduced by #3400.


Subtasks

Task #4829: Add testsResolvedTom Clegg

Task #4618: Find/confirm the commit that fixed thisResolvedTom Clegg

Task #4830: Review 4515-search-empty-projectResolvedTom Clegg

Associated revisions

Revision 70ffabfa
Added by Tom Clegg over 6 years ago

Merge branch '4515-search-empty-project' closes #4515

History

#1 Updated by Peter Amstutz almost 7 years ago

  • Subject changed from [Workbench] Fiddlesticks when selecting empty project in chooser to [Workbench] Oops when selecting empty project in chooser
  • Description updated (diff)

#2 Updated by Tom Clegg almost 7 years ago

  • Story points set to 0.5

#3 Updated by Tom Clegg almost 7 years ago

  • Target version changed from Bug Triage to Arvados Future Sprints

#4 Updated by Tom Clegg almost 7 years ago

Cannot reproduce on staging @ 6c68141, almost certainly fixed by 78447c7 during #4024.

#5 Updated by Tom Clegg almost 7 years ago

  • Category set to Workbench
  • Status changed from New to Feedback
  • Assigned To set to Tom Clegg

#6 Updated by Tom Clegg almost 7 years ago

  • Target version changed from Arvados Future Sprints to 2014-12-10 sprint

#7 Updated by Ward Vandewege almost 7 years ago

  • Target version changed from 2014-12-10 sprint to 2015-01-07 sprint

#8 Updated by Tom Clegg almost 7 years ago

This bug was fixed by 78447c70 (already merged, see #4024).

4515-search-empty-project @ 1c9e7c4 adds a few basic tests for SearchController, including an "empty project" test for this specific case.

#9 Updated by Tom Clegg almost 7 years ago

  • Status changed from Feedback to In Progress

#10 Updated by Brett Smith over 6 years ago

1c9e7c4 is good to merge, thanks.

#11 Updated by Anonymous over 6 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 78 to 100

Applied in changeset arvados|commit:70ffabfafec877a79cfd4ab5e4fb5831e37068fa.

Also available in: Atom PDF