Bug #4641

[Tests] A few projects related Workbench tests are failing in jenkins. Make them pass.

Added by Radhika Chippada about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Radhika Chippada
Category:
-
Target version:
Start date:
11/21/2014
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Story points:
0.5

Description

Looking at the fail-1.png, it appears that the page width used for the test is not wide enough and some of the buttons in project page (Add data, Run a pipeline, Add a subproject) are not visible. It might help to increase the page size for projects_test.rb.


Subtasks

Task #4648: Review branch: 4641-make-jenkins-tests-passResolvedRadhika Chippada

Associated revisions

Revision c9760bc4
Added by Radhika Chippada about 6 years ago

closes #4641
Merge branch '4641-make-jenkins-tests-pass'

History

#1 Updated by Radhika Chippada about 6 years ago

  • Description updated (diff)
  • Assigned To set to Radhika Chippada

#2 Updated by Tim Pierce about 6 years ago

  • Target version changed from Bug Triage to 2014-12-10 sprint

#3 Updated by Radhika Chippada about 6 years ago

  • Status changed from New to In Progress

#4 Updated by Radhika Chippada about 6 years ago

What changed:

  • Use selenium driver in projects_test.rb
  • Set slightly bigger browser width
  • Update three tests that failed.
    • Add "wait_for_ajax" for test 'Check collection count for A Project in the tab pane titles'. On a side note, I suspect this actually never worked correctly earlier because the count must always have been 0.
    • Add confirm dialog OK button click for sharing tests upon Revoke action.

#5 Updated by Brett Smith about 6 years ago

Reviewing 5b3a6fb

In current master, the projects integration tests all pass when run by themselves. This suggests that the problem is not the tests themselves, but that state is leaking between tests. I would prefer to see a solution that cleans up that state consistently, rather than patching over the projects tests. Otherwise, the leakage may cause surprising effects for other tests later.

The build started failing after #4592 was merged, which added a test that resizes the browser window. Perhaps Capybara doesn't reset the window back to its original state after that? But whatever state is leaking, plugging the leak would be a lot cleaner, I think.

#6 Updated by Radhika Chippada about 6 years ago

Brett: no, #4592 did not add window sizing. The window sizing was added for #3117 and we had several successful runs since then.

#7 Updated by Radhika Chippada about 6 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Applied in changeset arvados|commit:c9760bc4b644c0aa877fb4137d2f6eac585ed945.

#8 Updated by Ward Vandewege about 6 years ago

  • Story points set to 0.5

Also available in: Atom PDF