Bug #4672

[SDKs] KeepClient.put raises an exception on a block larger than 64MB

Added by Tim Pierce over 5 years ago. Updated over 5 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
-
Category:
SDKs
Target version:
-
Start date:
11/25/2014
Due date:
% Done:

0%

Estimated time:
Story points:
-

Description

Example:

>>> import arvados
>>> x = 'x' * 67108865
>>> len(x)
67108865
>>> hash = arvados.keep.KeepClient().put(x)
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/local/lib/python2.7/dist-packages/arvados/retry.py", line 157, in num_retries_setter
    return orig_func(self, *args, **kwargs)
  File "/usr/local/lib/python2.7/dist-packages/arvados/keep.py", line 719, in put
    (data_hash, copies, thread_limiter.done()))
arvados.errors.KeepWriteError: Write fail for 66e31f9f0968774cf4cb2dac211054b0: wanted 2 but wrote 0

While this isn't an operation we should expect to succeed, it would be useful for the user if KeepClient returned a more helpful error message.


Related issues

Is duplicate of Arvados - Bug #3835: [SDKs] Python and CLI tools should give more helpful error messages after a Keep failureResolved01/13/2015

History

#1 Updated by Tom Clegg over 5 years ago

  • Target version deleted (Bug Triage)

#2 Updated by Brett Smith over 5 years ago

  • Status changed from New to Resolved

Applied in changeset arvados|commit:952bfa87465a27f83dca7feca7d369fda4200eb5.

Also available in: Atom PDF