Bug #4676

[Workbench] Collection "Sharing link" AJAX intermittently returns text/html

Added by Brett Smith about 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assigned To:
Brett Smith
Category:
Workbench
Target version:
Start date:
11/25/2014
Due date:
% Done:

100%

Estimated time:
Story points:
0.5

Description

Steps to reproduce:

  • Go to a Collection's page.
  • In the "Sharing and permissions" box, alternate clicking on the "Create sharing link" and "Unshare" buttons.

Sooner or later, the text in the box will fail to toggle as it should. According to the browser console, this happens because the request headers say it's returning HTML. The content is actually JavaScript, but the header means the browser doesn't execute it as expected. Ensure that this method consistently returns JavaScript as its Content-Type.


Related issues

Copied from Arvados - Bug #4291: [Workbench] Create sharing link for a collection is brokenResolved10/28/2014

Associated revisions

Revision 994fa456
Added by Brett Smith almost 6 years ago

Merge branch '4291-workbench-collection-sharing-button-wip'

Closes #4291, #4676, #4688.

History

#1 Updated by Brett Smith about 6 years ago

  • Description updated (diff)

#2 Updated by Brett Smith almost 6 years ago

  • Status changed from New to In Progress
  • Assigned To set to Brett Smith
  • Target version changed from Bug Triage to 2014-12-10 sprint

#3 Updated by Brett Smith almost 6 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

Applied in changeset arvados|commit:994fa4569b8da43486719ce0da770ab1887b24b9.

Also available in: Atom PDF