Bug #4730

[SDKs] Remove ruby dependency from arv wrapper

Added by Brett Smith over 4 years ago. Updated almost 4 years ago.

Status:
New
Priority:
Normal
Assigned To:
-
Category:
SDKs
Target version:
Start date:
12/05/2014
Due date:
% Done:

0%

Estimated time:
Story points:
1.0

Description

In order to use the full set of CLI tools most users will use to interact with Arvados, you have to install both the Python and Ruby SDKs. This is poor UX: it's more dependencies to track down. This is exacerbated by the fact that Ruby isn't ubiquitous in the bioinformatician world; users who don't have Ruby installed already have to pull in a significant stack.

Please make the entire CLI suite available as one package. The easier it is to install across different flavors of Unix, the better.


Related issues

Related to Arvados - Story #5468: [SDKs] Refactor arv-get/put/copy into the Python "arv" wrapper using common exception-handling and argument parsingNew

Related to Arvados - Bug #7099: [SDKs] CLI SDK tools use Ruby SDKNew

History

#1 Updated by Tom Clegg over 4 years ago

  • Target version changed from Bug Triage to Arvados Future Sprints

#2 Updated by Tom Clegg over 4 years ago

  • Subject changed from [SDKs] Consolidate CLI tools to [SDKs] Remove ruby dependency from arv wrapper
  • Story points set to 1.0

Also available in: Atom PDF